summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-05-06 02:48:05 +0300
committerGitHub <noreply@github.com>2022-05-06 02:48:05 +0300
commitca8d06bc610af08c2d3efc487aa9519989b743e6 (patch)
treec557da2136640a8ce48439f19fe5f7071faffeca /meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb
parent7cf0c1cd0ce835d1833509b7b911e8a97380278b (diff)
parent18f97faa411078b95d042d207f5fff32bc8ece1d (diff)
downloadopenbmc-ca8d06bc610af08c2d3efc487aa9519989b743e6.tar.xz
Merge pull request #80 from Intel-BMC/updateHEAD1-0.91intel
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb b/meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb
new file mode 100644
index 000000000..85fe39b6d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/unifex/unifex_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "C++ Unified Executors library"
+HOMEPAGE = "https://github.com/facebookexperimental/libunifex"
+SECTION = "libs"
+LICENSE = "Apache-2.0-with-LLVM-exception"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b86506074cb3cdc493b4f96b73b2909"
+
+SRC_URI = "git://github.com/facebookexperimental/libunifex.git;branch=main;protocol=https"
+SRCREV = "9df21c58d34ce8a1cd3b15c3a7347495e29417a0"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG ??= "liburing"
+PACKAGECONFIG[liburing] = ",,liburing"
+
+EXTRA_OECMAKE += " \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_CXX_STANDARD=20 \
+ -DUNIFEX_BUILD_EXAMPLES=OFF \
+ "
+
+BBCLASSEXTEND = "native nativesdk"