summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
commitbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (patch)
tree00457d3677e86437cec25fd7dab6c4513a53b1a4 /meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
parentcf6fd27dbd8e2d1b507f8c3752b85801b2c6ef57 (diff)
downloadopenbmc-bb6a14e2f317abf60677c6ad8de9c33d5760bf36.tar.xz
Merge tag '0.63' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb b/meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb
new file mode 100644
index 000000000..307ee9b98
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/surf/surf_2.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Simple web browser"
+DESCRIPTION = "Simple open source web browser based on WebKit2/GTK"
+HOMEPAGE = "https://surf.suckless.org/"
+SECTION = "x11/graphics"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2a6f86d002ae9ae1eb1ccc466289f146"
+
+DEPENDS = "webkitgtk gtk+3 glib-2.0 gcr"
+
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
+
+SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \
+ file://0001-config.mk-Fix-compiler-and-linker.patch \
+"
+SRCREV = "bcd7d74e613fb8af11b40c351f0a6c1a771b2d2b"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig features_check
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install () {
+ install -D -m 0755 ${S}/surf ${D}${bindir}/surf
+}