summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
commitbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (patch)
tree00457d3677e86437cec25fd7dab6c4513a53b1a4 /meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
parentcf6fd27dbd8e2d1b507f8c3752b85801b2c6ef57 (diff)
downloadopenbmc-bb6a14e2f317abf60677c6ad8de9c33d5760bf36.tar.xz
Merge tag '0.63' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch24
1 files changed, 10 insertions, 14 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
index 4116ae7d1..99cb87b30 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
+++ b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
@@ -1,19 +1,15 @@
-Index: git/framework/delibs/dethread/CMakeLists.txt
-===================================================================
---- git.orig/framework/delibs/dethread/CMakeLists.txt
-+++ git/framework/delibs/dethread/CMakeLists.txt
-@@ -39,6 +39,7 @@ include_directories(
-
- if (DE_OS_IS_UNIX)
- add_definitions(-D_GNU_SOURCE)
+--- a/framework/delibs/dethread/CMakeLists.txt
++++ b/framework/delibs/dethread/CMakeLists.txt
+@@ -42,6 +42,7 @@ if (DE_OS_IS_UNIX)
+ add_definitions(-D__BSD_VISIBLE)
+ add_definitions(-D_XOPEN_SOURCE=600)
+ endif ()
+ add_definitions(-D_XOPEN_SOURCE=600)
- set(DETHREAD_LIBS ${DETHREAD_LIBS} pthread)
- endif ()
+ add_definitions(-D_GNU_SOURCE)
-Index: git/framework/qphelper/CMakeLists.txt
-===================================================================
---- git.orig/framework/qphelper/CMakeLists.txt
-+++ git/framework/qphelper/CMakeLists.txt
+ set(DETHREAD_LIBS ${DETHREAD_LIBS} pthread)
+--- a/framework/qphelper/CMakeLists.txt
++++ b/framework/qphelper/CMakeLists.txt
@@ -28,6 +28,7 @@ set(QPHELPER_LIBS
if (DE_OS_IS_UNIX OR DE_OS_IS_QNX)
# For vsnprintf()