summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:50 +0300
commita891d150c6a7455ddbb797bdc472f45fd5f36008 (patch)
tree675a1c6f76065884b0c99b5a6056c79de44ef083 /meta-openembedded/meta-oe/recipes-kernel
parent4bfffde7b5edeee761d32b174386bd1e1e28fab9 (diff)
downloadopenbmc-a891d150c6a7455ddbb797bdc472f45fd5f36008.tar.xz
meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3): python3-cmd2: Remove PNBLACKLIST php: Remove no longer needed CFLAGS_append_aarch64 php: Move more into php.inc after php5 removal Alistair Francis (4): python3-requests-future: Initial commit of 0.9.5 python3-xmlrunner: Initial commit of 1.7.7 python3-fasteners: Initial commit of 0.15 python3-python-vlc: Initial commit of 3.0.7110 Anuj Mittal (3): python3-defusedxml: add recipe python-networkx: upgrade 2.1 -> 2.2 python3-networkx: add recipe Khem Raj (9): php: Turn PCRE JIT off for riscv redis: Fix build with clang/x86 android-tools: Recognise i686 for HOST_ARCH netdata: Update to 1.17.0 and fix build with clang/x86 safec: Define _GNU_SOURCE safec: Upgrade to 3.5 release openocd: Add --disable-werror always breakpad: Update dont-clobber-rsp patch to latest gparted: add to deps instead of overwriting Martin Jansa (3): remmina: add distro_features_check for GTK3DISTROFEATURES ceres-solver: fix the paths in .cmake files ceres-solver: add PACKAGECONFIG for suitesparse and lapack Naveen Saini (1): pm-graph: upgrade 5.3 -> 5.5 Oleksandr Kravchuk (1): analyze-suspend: update to 5.5 Peter Kjellerstedt (1): lvm2/libdevmapper: Make it build for native Randy MacLeod (1): poppler: update from 0.79.0 to 0.80.0 Slater, Joseph (1): openhpi: control snmp-bc ptest generation Stefan Agner (1): fuse3: add libfuse3 recipe Trevor Gamblin (1): gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes Yi Zhao (2): php: fix module path in mod_php.conf apache-websocket: fix module path Yuan Chao (2): python-atomicwrites: new recipe python-pytest: fix runtime error Zang Ruochen (1): python-certifi: upgrade 2019.6.16 -> 2019.9.11 Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-kernel')
-rw-r--r--meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb (renamed from meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb)6
3 files changed, 42 insertions, 35 deletions
diff --git a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
deleted file mode 100644
index d49ce0138..000000000
--- a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 0c94e32b218c31f31a7988577fb9bec595034e7b Mon Sep 17 00:00:00 2001
-From: Todd Brandt <todd.e.brandt@linux.intel.com>
-Date: Fri, 10 May 2019 15:10:35 -0700
-Subject: [PATCH] bootgraph.py: - handle boot time start grep better, the regex
- needs more complexity
-
-Upstream-Status: Backport [https://github.com/intel/pm-graph/commit/0c94e32b218c31f31a7988577fb9bec595034e7b]
-
-Signed-off-by: Liwei Song <liwei.song@windriver.com>
----
- bootgraph.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/bootgraph.py b/bootgraph.py
-index a2b1b1897307..d7f4bd152bf1 100755
---- a/bootgraph.py
-+++ b/bootgraph.py
-@@ -333,9 +333,9 @@ def parseKernelLog():
- if(not sysvals.stamp['kernel']):
- sysvals.stamp['kernel'] = sysvals.kernelVersion(msg)
- continue
-- m = re.match('.* setting system clock to (?P<t>.*) UTC.*', msg)
-+ m = re.match('.* setting system clock to (?P<d>[0-9\-]*)[ A-Z](?P<t>[0-9:]*) UTC.*', msg)
- if(m):
-- bt = datetime.strptime(m.group('t'), '%Y-%m-%d %H:%M:%S')
-+ bt = datetime.strptime(m.group('d')+' '+m.group('t'), '%Y-%m-%d %H:%M:%S')
- bt = bt - timedelta(seconds=int(ktime))
- data.boottime = bt.strftime('%Y-%m-%d_%H:%M:%S')
- sysvals.stamp['time'] = bt.strftime('%B %d %Y, %I:%M:%S %p')
---
-2.22.0
-
diff --git a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch
new file mode 100644
index 000000000..25c87093f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch
@@ -0,0 +1,39 @@
+From 22ce65d997f99606a3bb9d2a660ead42eecc234a Mon Sep 17 00:00:00 2001
+From: Naveen Saini <naveen.kumar.saini@intel.com>
+Date: Wed, 11 Sep 2019 11:31:07 +0800
+Subject: [PATCH] sleepgraph.py: use python3
+
+Already compatible with Python 3.
+Same goes for bootgraph.py
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
+---
+ bootgraph.py | 2 +-
+ sleepgraph.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bootgraph.py b/bootgraph.py
+index d3b99a1..efb5714 100755
+--- a/bootgraph.py
++++ b/bootgraph.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ # SPDX-License-Identifier: GPL-2.0-only
+ #
+ # Tool for analyzing boot timing
+diff --git a/sleepgraph.py b/sleepgraph.py
+index 1794c79..cfed8e0 100755
+--- a/sleepgraph.py
++++ b/sleepgraph.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ # SPDX-License-Identifier: GPL-2.0-only
+ #
+ # Tool for analyzing suspend/resume timing
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
index a9f540ab8..63a9fa88e 100644
--- a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
+++ b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
@@ -5,10 +5,10 @@ HOMEPAGE = "https://01.org/pm-graph"
LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
-SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7"
+SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
SRC_URI = "git://github.com/intel/pm-graph.git \
file://0001-Makefile-fix-multilib-build-failure.patch \
- file://0001-bootgraph.py.patch \
+ file://0001-sleepgraph.py-use-python3.patch \
"
S = "${WORKDIR}/git"
@@ -19,4 +19,4 @@ do_install() {
oe_runmake install
}
-RDEPENDS_${PN} += "python-core python-threading python-datetime python-subprocess python-compression"
+RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"