summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-11-05 18:45:06 +0300
committerGitHub <noreply@github.com>2021-11-05 18:45:06 +0300
commit4dac5fcd49b5e2de1074f1363775ec0f19041072 (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
parent0c9e31989c615598b5d042ffab385606660c93c0 (diff)
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
downloadopenbmc-4dac5fcd49b5e2de1074f1363775ec0f19041072.tar.xz
Merge pull request #74 from Intel-BMC/update2021-0.771-0.77
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
new file mode 100644
index 000000000..4641b0181
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
@@ -0,0 +1,24 @@
+require dfu-util_${PV}.bb
+
+inherit deploy native
+
+DEPENDS = "libusb1-native"
+
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
+
+do_deploy() {
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
+ rm -f ${DEPLOYDIR}/dfu-util
+ ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
+}
+
+addtask deploy before do_package after do_install
+
+# cleandirs should possibly be in deploy.bbclass but we need it
+do_deploy[cleandirs] = "${DEPLOYDIR}"
+# clear stamp-extra-info since MACHINE_ARCH is normally put there by
+# deploy.bbclass
+do_deploy[stamp-extra-info] = ""
+