summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/dhex
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-23 15:01:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-23 16:18:15 +0300
commitdec060e0fadb20cc708370ae192db4462283ee58 (patch)
treec239cdb9a5f7c4f0f022babb75115b5a5eb0e69c /meta-openembedded/meta-oe/recipes-support/dhex
parentaca8d6e0500430a0cba0b1ebd1099cd709bafcc1 (diff)
downloadopenbmc-dec060e0fadb20cc708370ae192db4462283ee58.tar.xz
meta-openembedded: subtree update:ef1b17f4ef..290ad988fb
Alistair Francis (6): python3-padaos: Initial commit of version 0.1.10 python3-padatious: Initial commit of 0.4.7 python3-petact: Initial commit of version 0.1.2 python3-precise-runner: Initial commit of version 0.3.1 python3-pulsectl: Initial version of 18.12.5 python3-pychromecast: Initial commit of version 4.0.1 Bartosz Golaszewski (1): python-jsonschema: add python-setuptools-scm to RDEPENDS Daniel Ammann (1): dhex: Add new recipe Khem Raj (5): dfu-utils: Switch src_uri to sourceforge.net dfu-util-native: Dont build static binary live555: Switch SRC_URI where archives are kept for longer kernel-selftest: Exclude from world builds uim: Update to 1.8.8 Oleksandr Kravchuk (2): pcsc-lite: update to 1.8.25 xf86-video-nouveau: update to 1.0.16 Ricardo Salveti (2): python-pyrsistent: add recipe python-jsonschema: rdepends on attrs and pyrsistent S. Lockwood-Childs (1): wireshark: remove restriction to ARM ISA Slater, Joseph (1): live555: update to version 20190828 Vincent Prince (3): python*-psutil: Add native and nativesdk to BBCLASSEXTEND python3-cheetah: add recipe python3-regex: add recipe Yuan Chao (8): python-more-itertools: new recipe python-zipp: new recipe python-pathlib2: new recipe python-packaging: new recipe python-importlib-metadata: new recipe python-pytest: fix runtime error libtevent: upgrade 0.10.0 -> 0.10.1 cryptsetup: upgrade 2.2.0 -> 2.2.1 cjhasu (1): Remove "werkzeug-test" in RDEPENDS Change-Id: Ideadf7469c094d3f26382af6203403ac5c29c6ee Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/dhex')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dhex/dhex_0.69.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/dhex/dhex_0.69.bb b/meta-openembedded/meta-oe/recipes-support/dhex/dhex_0.69.bb
new file mode 100644
index 000000000..cfbb2caaf
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/dhex/dhex_0.69.bb
@@ -0,0 +1,24 @@
+SUMMARY = "dhex is a hex editor that includes a diff mode"
+SECTION = "console/utils"
+
+DEPENDS = "ncurses"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://README.txt;beginline=229;endline=241;md5=6f252a421b65bcecf624382ba3c899da"
+
+SRC_URI = "http://www.dettus.net/dhex/dhex_0.69.tar.gz"
+SRC_URI[md5sum] = "64d557437fe110c19f23ed3e9bbcdd54"
+SRC_URI[sha256sum] = "52730bcd1cf16bd4dae0de42531be9a4057535ec61ca38c0804eb8246ea6c41b"
+
+S = "${WORKDIR}/dhex_${PV}"
+
+EXTRA_OEMAKE += "'CC=${CC}' 'LDFLAGS=${LDFLAGS}' 'CPPFLAGS=${CPPFLAGS}'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/dhex ${D}${bindir}/
+}