summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-07 16:34:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-07 16:34:54 +0300
commit4fe7a1353f8f7f96c7407caa3352fa50fcce5aa3 (patch)
treee1e898e098bec469e02e357983dae7436a072235 /meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb
parent00e122a7b3a839f5ce8b819cb1bfe92cf3781eda (diff)
downloadopenbmc-4fe7a1353f8f7f96c7407caa3352fa50fcce5aa3.tar.xz
meta-openembedded: subtree update:e6d76b05a7..01d539b324
Adrian Ratiu (1): renderdoc: add x11 to REQUIRED_DISTRO_FEATURES Callaghan, Dan (2): firewalld: update to 0.7.1 strongswan: install dev headers George McCollister (1): wireshark: fix qt5 build Jean-Marie LEMETAYER (1): python-toml: add recipes for python2 and python3 Khem Raj (1): xscreensaver: Remove xserver-nodm-init rdep Maciej Pijanowski (1): smem: package smemcap separately Ovidiu Panait (1): kea: Disable parallel install Peiran Hong (1): zabbix: upgrade 3.0.9 -> 4.2.6 Randy MacLeod (1): libteam: update from 1.28 to 1.29 Trevor Gamblin (2): php: fix CVE-2019-6978 gd: fix CVE-2019-6978 Change-Id: I2c308ff46213876c1d74f42b5d9f9e52946bbf02 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb b/meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb
new file mode 100644
index 000000000..821ca1938
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libteam/libteam_1.29.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Library for controlling team network device"
+HOMEPAGE = "http://www.libteam.org/"
+SECTION = "libs/network"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libnl libdaemon jansson"
+
+SRC_URI = "git://github.com/jpirko/libteam \
+ file://0001-include-sys-select.h-for-fd_set-definition.patch \
+ file://0002-teamd-Re-adjust-include-header-order.patch \
+ file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
+ file://run-ptest \
+ "
+SRCREV = "e897f02bf2403d4859a99e090e34ea768b4c0540"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig ptest
+
+FILES_${PN} = "${libdir}/libteam${SOLIBS} \
+"
+
+PACKAGES += "${PN}-dctl ${PN}-utils"
+FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \
+"
+FILES_${PN}-utils = "${bindir}/bond2team \
+ ${bindir}/teamd \
+ ${bindir}/teamdctl \
+ ${bindir}/teamnl \
+"
+
+RDEPENDS_${PN}-utils = "bash"
+RDEPENDS_${PN}-ptest = "python"
+
+do_install_ptest() {
+ install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/
+}