summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/poppler
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-openembedded/meta-oe/recipes-support/poppler
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/poppler')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/poppler/poppler-data_0.4.10.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.08.0.bb (renamed from meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.07.0.bb)12
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/poppler/poppler-data_0.4.10.bb b/meta-openembedded/meta-oe/recipes-support/poppler/poppler-data_0.4.10.bb
index 46e33514e..7574c7b5b 100644
--- a/meta-openembedded/meta-oe/recipes-support/poppler/poppler-data_0.4.10.bb
+++ b/meta-openembedded/meta-oe/recipes-support/poppler/poppler-data_0.4.10.bb
@@ -34,4 +34,4 @@ do_install() {
install -m644 ${WORKDIR}/Identity-* ${D}${datadir}/poppler/cMap/
}
-FILES_${PN} += "${datadir}"
+FILES:${PN} += "${datadir}"
diff --git a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.07.0.bb b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.08.0.bb
index 975ab1d70..1fc3bf3f4 100644
--- a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.07.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_21.08.0.bb
@@ -7,7 +7,7 @@ SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
file://0001-Do-not-overwrite-all-our-build-flags.patch \
file://basename-include.patch \
"
-SRC_URI[sha256sum] = "e26ab29f68065de4d6562f0a3e2b5435a83ca92be573b99a1c81998fa286a4d4"
+SRC_URI[sha256sum] = "e9cf5dc5964bce4bb0264d1c4f8122706c910588b421cfc30abc97d6b23e602d"
DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
@@ -21,7 +21,7 @@ PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
-PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON,-DENABLE_SPLASH=OFF,boost"
+PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON -DENABLE_BOOST=ON,-DENABLE_SPLASH=OFF -DENABLE_BOOST=OFF,boost"
# surprise - did not expect this to work :)
inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
@@ -37,7 +37,7 @@ EXTRA_OECMAKE += " \
${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
"
-do_configure_append() {
+do_configure:append() {
# poppler macro uses pkg-config to check for g-ir runtimes. Something
# makes them point to /usr/bin. Align them to sysroot - that's where the
# gir-wrappers are:
@@ -45,7 +45,7 @@ do_configure_append() {
}
PACKAGES =+ "libpoppler libpoppler-glib"
-FILES_libpoppler = "${libdir}/libpoppler.so.*"
-FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
+FILES:libpoppler = "${libdir}/libpoppler.so.*"
+FILES:libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
-RDEPENDS_libpoppler = "poppler-data"
+RDEPENDS:libpoppler = "poppler-data"