summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
commit9722c6ee87766a45a337c094d1293de81cdcb106 (patch)
tree08b57716ae3c02fef2bc870b634019e692fd70e6 /meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
parent35e295e2a161fcf146ea031de53431b2888521fa (diff)
parent5b6cc97bf138293b6af12d5d3003bb66c700c48a (diff)
downloadopenbmc-9722c6ee87766a45a337c094d1293de81cdcb106.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into HEAD
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb b/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
new file mode 100644
index 000000000..01b1ac384
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/tree/tree_1.8.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A recursive directory listing command"
+HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
+SRC_URI[md5sum] = "715191c7f369be377fc7cc8ce0ccd835"
+SRC_URI[sha256sum] = "715d5d4b434321ce74706d0dd067505bb60c5ea83b5f0b3655dae40aa6f9b7c2"
+
+# tree's default CFLAGS for Linux
+CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_configure[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/
+}