summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-perl/recipes-extended/mime-construct
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-openembedded/meta-perl/recipes-extended/mime-construct
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-perl/recipes-extended/mime-construct')
-rw-r--r--meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch39
-rw-r--r--meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb28
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch b/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch
new file mode 100644
index 000000000..5e4281d4e
--- /dev/null
+++ b/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch
@@ -0,0 +1,39 @@
+From 2b9ed06850410d70371b31de5f131e484ba1c851 Mon Sep 17 00:00:00 2001
+From: Lu Chong <Chong.Lu@windriver.com>
+Date: Thu, 17 Oct 2013 16:06:04 +0800
+Subject: [PATCH] fix mime-construct --help return value
+
+Upstream-Status: Pending
+
+Signed-off-by: Lu Chong <Chong.Lu@windriver.com>
+
+---
+ mime-construct | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/mime-construct b/mime-construct
+index cad7d0e..707ed19 100755
+--- a/mime-construct
++++ b/mime-construct
+@@ -39,7 +39,7 @@ usage: $Me switch...
+
+ Global settings:
+ --debug turn debugging on
+- --help show this and then die
++ --help show this
+ --output don\'t mail, output to stdout (loses bcc info)
+ --subpart generate subpart rather than whole message (turns
+ on --output, changes other semantics a bit)
+@@ -150,7 +150,8 @@ sub xwarn {
+
+ sub usage {
+ xwarn @_ if @_;
+- die $Usage;
++ print $Usage;
++ exit 0;
+ }
+
+ sub init {
+--
+1.7.9.5
+
diff --git a/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
new file mode 100644
index 000000000..501f3bf14
--- /dev/null
+++ b/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Construct and optionally mail MIME messages"
+DESCRIPTION = "Constructs and (by default) mails MIME messages. \
+ It is entirely driven from the command line, it is \
+ designed to be used by other programs, or people who act \
+ like programs."
+HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct"
+SECTION = "mail"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \
+ file://fix-mime-construct-help-return-value.patch \
+"
+
+SRC_URI[md5sum] = "73834ea780fbea81b89dbd9b2fb54f58"
+SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303"
+
+inherit cpan
+
+RDEPENDS_${PN} = "libmime-types-perl libproc-waitstat-perl msmtp \
+ perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
+"
+
+do_install_append() {
+ #change the interpreter in file
+ sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
+ ${D}/${bindir}/mime-construct
+}