summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-08-02 02:10:54 +0300
committerGitHub <noreply@github.com>2019-08-02 02:10:54 +0300
commit25ad46338e5990f081ef280429a5fc8ada5735be (patch)
tree4c0e3cb32dc80f80460bdbf82ff6d401d4ff194f /meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
parent43a183cc0926da36e3a218efa02ab4838ace316f (diff)
parentd0f63ef62c76c932a2003eaa42c0b250065ae06f (diff)
downloadopenbmc-25ad46338e5990f081ef280429a5fc8ada5735be.tar.xz
Merge pull request #14 from Intel-BMC/update4
Update4
Diffstat (limited to 'meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb')
-rw-r--r--meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb b/meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
index 9753520ae..6fabf2684 100644
--- a/meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
+++ b/meta-openembedded/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
@@ -35,7 +35,7 @@ SRC_URI[libxml.sha256sum] = "f0bca4d0c2da35d879fee4cd13f352014186cedab27ab5e191f
S = "${WORKDIR}/XML-LibXML-${PV}"
-inherit cpan
+inherit cpan ptest-perl
EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
@@ -45,3 +45,27 @@ CFLAGS += " -D_GNU_SOURCE "
BUILD_CFLAGS += " -D_GNU_SOURCE "
FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"
+
+RDEPENDS_${PN}-ptest += " \
+ liburi-perl \
+ perl-module-encode-byte \
+ perl-module-encode-unicode \
+ perl-module-locale \
+ perl-module-perlio-scalar \
+ perl-module-test-more \
+"
+
+do_install_prepend() {
+ # test requires "-T" (taint) command line option
+ rm -rf ${B}/t/pod.t
+ # this only applies to author build
+ rm -rf ${B}/t/pod-files-presence.t
+}
+
+do_install_ptest() {
+ cp -r ${B}/t/data ${D}${PTEST_PATH}/t/
+ cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
+ cp -r ${B}/example ${D}${PTEST_PATH}
+ cp -r ${B}/test ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}
+}