summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:31 +0300
commit36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d (patch)
tree9480192d0cca5018cf5a364d4931b90694b96aec /meta-openembedded/meta-python
parent63417d1f540c12c3e0b456409555ecbe50f39875 (diff)
downloadopenbmc-36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d.tar.xz
meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1): networkmanager: Correct the upstream version check Adrian Ratiu (1): renderdoc: add new recipe Changqing Li (1): kea: upgrade 1.5.0 -> 1.7.0 Denys Dmytriyenko (1): rwmem: add recipe Hongxu Jia (1): lvm2: fix run lvcreate hung while PACKAGECONFIG udev Jackie Huang (6): python-versiontools: add recipes for python2 and python3 python-pymysql: add recipes for python2 and python3 python-statistics: add new recipe python-pyperf: add recipes for python2 and python3 python-pika: add recipes for python2 and python3 python-pycurl: add recipes for python2 and python3 Khem Raj (6): openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl ttf-gentium: Use OFL-1.0 version of OFL license ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file python-configparser: Mark license as MIT fontforge: Upgrade to 20190801 release opensaf: Fix duplicate copies of shared libs in package Martin Jansa (2): spice: ignore all warnings not just address-of-packed-member Revert "spice: Drop broken native" Otavio Salvador (5): networkmanager: Fix ADSL plugin packaging networkmanager: Add a `resolvconf` PACKAGECONFIG networkmanager: Add sysvinit support libqmi: Upgrade 1.22.2 -> 1.24.0 modemmanager: Upgrade 1.10.0 -> 1.10.2 Qi.Chen@windriver.com (1): protobuf-c: fix race condition Robert Yang (2): corosync: Fix PACKAGECONFIG flag for rdma net-snmp: Fix PACKAGECONFIG for perl Zang Ruochen (1): python-urllib3: upgrade 1.25.5 -> 1.25.6 Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-configparser.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pika.inc22
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pika_1.1.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pycurl.inc26
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pymysql.inc18
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyperf.inc23
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb15
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-urllib3.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.6.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.5.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-versiontools.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.6.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.5.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb2
20 files changed, 141 insertions, 3 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-configparser.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-configparser.inc
index 7f4385e77..a1fb6cd29 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-configparser.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-configparser.inc
@@ -1,7 +1,7 @@
SUMMARY = "This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what's found in Microsoft Windows INI files."
SECTION = "devel/python"
HOMEPAGE = "https://docs.python.org/3/library/configparser.html"
-LICENSE = "unknown"
+LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=23f9ad5cad3d8cc0336e2a5d8a87e1fa"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pika.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pika.inc
new file mode 100644
index 000000000..10be5bb62
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pika.inc
@@ -0,0 +1,22 @@
+SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python."
+DESCRIPTION = " \
+Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \
+including RabbitMQ’s extensions. \
+"
+SECTION = "devel/python"
+HOMEPAGE = "https://pika.readthedocs.io"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=535836bf0a5de515a7bfee026075701d"
+
+SRC_URI[md5sum] = "6002400cdd33bf85ec8680ece72910d4"
+SRC_URI[sha256sum] = "9fa76ba4b65034b878b2b8de90ff8660a59d925b087c5bb88f8fdbb4b64a1dbf"
+
+inherit pypi
+
+PYPI_PACKAGE = "pika"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-tornado \
+ ${PYTHON_PN}-twisted \
+"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pika_1.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pika_1.1.0.bb
new file mode 100644
index 000000000..f7e019867
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pika_1.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pika.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl.inc
new file mode 100644
index 000000000..ac9a370c4
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl.inc
@@ -0,0 +1,26 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = " \
+ file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=2df767ed35d8ea83de4a93feb55e7815 \
+"
+
+SRC_URI[md5sum] = "f0ed4c805e8bec734990e2e0ee78568e"
+SRC_URI[sha256sum] = "6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e"
+
+inherit pypi
+
+PYPI_PACKAGE = "pycurl"
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
new file mode 100644
index 000000000..7ab259265
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pycurl.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql.inc
new file mode 100644
index 000000000..8c7f4556c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql.inc
@@ -0,0 +1,18 @@
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
+SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"
+
+inherit pypi
+
+PYPI_PACKAGE = "PyMySQL"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb
new file mode 100644
index 000000000..27d097ee6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pymysql_0.9.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pymysql.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf.inc
new file mode 100644
index 000000000..81837f300
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf.inc
@@ -0,0 +1,23 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "d67fe5f447963da8873f3e9923f76de1"
+SRC_URI[sha256sum] = "8d0143a22a13ee10c997a648f30b82cdc40175d5a20b11055ae058a82e45d371"
+
+inherit pypi
+
+PYPI_PACKAGE = "pyperf"
+
+DEPENDS += "${PYTHON_PN}-six-native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb
new file mode 100644
index 000000000..a9d5c7488
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-pyperf.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-statistics"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb
new file mode 100644
index 000000000..ee3b822a7
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A port of Python 3.4 statistics module to Python 2.x"
+DESCRIPTION = " \
+A port of Python 3.4 statistics module to Python 2.*, initially done \
+through the 3to2 tool. This module provides functions for calculating \
+mathematical statistics of numeric (Real-valued) data. \
+"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://statistics/__init__.py;beginline=6;endline=16;md5=b76960ee777a1529f60db47ada2a8e6e"
+
+SRC_URI[md5sum] = "d6d97f3a1a7b3192cff99e0f2b5956c3"
+SRC_URI[sha256sum] = "2dc379b80b07bf2ddd5488cad06b2b9531da4dd31edb04dc9ec0dc226486c138"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "statistics"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3.inc
index 8825e2f4a..398b5f2ac 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "https://github.com/shazow/urllib3"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=65715c2eb961313d71b297dd5a04f85e"
-SRC_URI[md5sum] = "4dac6043f7603c5082ef6d629c6d81b3"
-SRC_URI[sha256sum] = "2f3eadfea5d92bc7899e75b5968410b749a054b492d5a6379c1344a1481bc2cb"
+SRC_URI[md5sum] = "a7504a9fcb7ed4ffa482fe098c80b6d4"
+SRC_URI[sha256sum] = "9a107b99a5393caf59c7aa3c1249c16e6879447533d0887f4336dde834c7be86"
RDEPENDS_${PN} += "\
${PYTHON_PN}-certifi \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.6.bb
index 6c81f1db9..6c81f1db9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.5.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-urllib3_1.25.6.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools.inc
new file mode 100644
index 000000000..b0e696f9c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Smart replacement for plain tuple used in __version__"
+SECTION = "devel/python"
+HOMEPAGE = "https://launchpad.net/versiontools"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=3;endline=20;md5=02193721a38fd8a05a4ddeb7df8e294d"
+
+inherit pypi
+
+SRC_URI[md5sum] = "602b7db8eea30dd29a1d451997adf251"
+SRC_URI[sha256sum] = "a969332887a18a9c98b0df0ea4d4ca75972f24ca94f06fb87d591377e83414f6"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb
new file mode 100644
index 000000000..6bfe82e00
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-versiontools.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb
new file mode 100644
index 000000000..a1515881f
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pika.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
new file mode 100644
index 000000000..5ad319ae2
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pycurl.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
new file mode 100644
index 000000000..13774bd63
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pymysql.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb
new file mode 100644
index 000000000..5ba5efb05
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb
@@ -0,0 +1,4 @@
+inherit setuptools3
+require python-pyperf.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-misc"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.6.bb
index 19eb7025b..19eb7025b 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.5.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-urllib3_1.25.6.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb
new file mode 100644
index 000000000..e8d6b7dda
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-versiontools.inc