summaryrefslogtreecommitdiff
path: root/meta-openembedded
diff options
context:
space:
mode:
authorVijay Khemka <vijaykhemka@fb.com>2020-08-10 22:32:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-18 21:10:48 +0300
commit6e220b3d1bdd75972a28a4f4cb11d3c00b9def91 (patch)
tree0d2f56224a5fcff85b54397fd60917c54184aca4 /meta-openembedded
parent15c7329524f7947ca98c02dc50be1c28c1ac647d (diff)
downloadopenbmc-6e220b3d1bdd75972a28a4f4cb11d3c00b9def91.tar.xz
Adding recipe for exprtk
The C++ Mathematical Expression Toolkit Library (ExprTk) is a simple to use, easy to integrate and extremely efficient run-time mathematical expression parsing and evaluation engine. The parsing engine supports numerous forms of functional and logic processing semantics and is easily extensible. It is a header only library. Signed-off-by: Vijay Khemka <vijaykhemka@fb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Change-Id: Ib5903421678afbce6b20c1b8e3a7ea9395100f25
Diffstat (limited to 'meta-openembedded')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/exprtk/exprtk_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/exprtk/exprtk_git.bb b/meta-openembedded/meta-oe/recipes-devtools/exprtk/exprtk_git.bb
new file mode 100644
index 000000000..6930f31e9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/exprtk/exprtk_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Expression parser"
+HOMEPAGE = "https://github.com/ArashPartow/exprtk"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+SRCREV = "281c2ccc65b8f91c012ea3725ebcef406378a225"
+
+SRC_URI = "git://github.com/ArashPartow/exprtk.git"
+
+S = "${WORKDIR}/git"
+
+# other packages commonly reference the file directly as "exprtk.hpp"
+# create symlink to allow this usage
+do_install() {
+ install -d ${D}/${includedir}
+ install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
+}
+
+# exprtk is a header only C++ library, so the main package will be empty.
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"