summaryrefslogtreecommitdiff
path: root/meta-openembedded
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-04-29 02:01:43 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-29 22:22:28 +0300
commit966452e73a71a508bea9049628363f1230ae7024 (patch)
treee6e952f4157a5a7feb8b757fc66a30dfb257eba9 /meta-openembedded
parent6c4a93c97a4a9de3f0dafe002668d37ae7f71056 (diff)
downloadopenbmc-966452e73a71a508bea9049628363f1230ae7024.tar.xz
python3-distro: native and nativesdk support
This is a cherry pick of an upstream change in meta-openembedded: https://github.com/openembedded/meta-openembedded/commit/79dd17c7b05c0951ee791c2f790bf9b83194ef6e This is required to get croserver bumped up to python3 due to a deprecated function that it needs moving to this new package (and out of the python2 package it was using). Can not move to the latest upstream code until croserver works, can't get croserver working until we get to latest upstream. So will merge this, merge croserver, then rebase on upstream meta-openembedded to officially get this change. Have a project that needs the native version of this recipe Change-Id: I03d245b42ae9b534e5d626e412e8e24f58ece1cd Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-openembedded')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-distro_1.5.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-distro_1.5.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-distro_1.5.0.bb
new file mode 100644
index 000000000..aaaee0dee
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-distro_1.5.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Distro is an OS platform information API"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+PYPI_PACKAGE = "distro"
+
+SRC_URI[md5sum] = "0ed68b4064709bdaaf6cce69780ddc51"
+SRC_URI[sha256sum] = "0e58756ae38fbd8fc3020d54badb8eae17c5b9dcbed388b17bb55b8a5928df92"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"