summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/ecmd
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2020-01-03 05:53:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-08 16:22:12 +0300
commitac6d51c60516fdd75d765e5b5be3e8519a8eb1b7 (patch)
treedaf6149b3099449137236c5a6c68a20c100cf0e5 /meta-openpower/recipes-bsp/ecmd
parentdc31c054fe2e85e084e0c4555a6cc7d258936f93 (diff)
downloadopenbmc-ac6d51c60516fdd75d765e5b5be3e8519a8eb1b7.tar.xz
croserver: Bump for fsi device path fix
Upstream now accepts linker flags from the environment, so remove the hard codeded --hash-style=gnu option from the conigure step. Jason Albert (3): Add ecmdChipTarget hash support to pyapi Defined __deepcopy__ functions on classes Added python support for vector<vector<databuffer>> Joel Stanley (2): Fix device paths again server: Fix linking Kahn Evans (10): More complete use of ECMD_REMOVE_SCOM_FUNCTIONS compile flag Use chipUnitNum instead of core in targets Resolve doxygen errors/warnings Adding spy APIs to pass in multiple images Updated query code as well Use const ecmdChipTargets in new APIs update to version 14.19 Revert to checking all return codes instead of just a single one for non-enum retry. Syncing up with what's in Cronus Use system _AIX compile flag Lakshminarayana R. Kammath (1): Adding support for LDFLAGS and SLDFLAGS to pickup value from environment Matt K. Light (6): update fapi2::ReturnCode get/putspi get/putspi links and htxt fix doxygen param name fix serverlock authorization storage fix target for ecmdGetPbaUnit (From meta-openpower rev: c02a90c17ab5b19bd1c2d4db3cb5af78ac474b2a) Change-Id: If64c0394ed0d39cac432c205785eb4ce2069d662 Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-bsp/ecmd')
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index 01005f8fa..e34dba123 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -4,20 +4,15 @@ LICENSE= "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
SRC_URI = "git://github.com/open-power/eCMD.git"
-SRCREV = "6c0348b12c95b3bd6e8d8003f9ff743d25400ae2"
+SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
DEPENDS += "python-native zlib"
SRC_URI += "file://croserver.service"
S = "${WORKDIR}/git"
-# Add the hash style option here to Work around this warning:
-# "QA Issue: No GNU_HASH in the elf binary"
-#
-# The recipe cannot set LDFLAGS in the environment as it overrides the
-# internal settings.
do_configure() {
- LD="${CXX} -Wl,--hash-style=gnu" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
+ LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
}
do_compile() {