summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/ipl
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2021-06-21 15:24:01 +0300
committerJayanth Othayoth <ojayanth@in.ibm.com>2021-06-30 16:43:14 +0300
commit1e40a42c7c1ce8608bfb406f3fedab05ef066f81 (patch)
tree79da41f6fbccb94ff8748e66c8295d92639a1e87 /meta-openpower/recipes-bsp/ipl
parent0e656dde2411c07ab9680ec2de36ede0e3b9b8d7 (diff)
downloadopenbmc-1e40a42c7c1ce8608bfb406f3fedab05ef066f81.tar.xz
meta-openpower: Add ipl support
Library provides support to boot POWER based host. Boot process covers time between power on and running the hypervisor. Also provide istep (Boot step defined by ecmd interface) back-end support. This library provides interface to OpenBMC apps to execute required hardware procedure based istep execution and custom POWER processor based initialisation functions. This requires, - pdbg (harwdare access layer) - POWER devicetree - libekb ( Harwdare procedure support) Repository: https://github.com/open-power/ipl Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: I853392a8e6a62cbc9c3135f8fc23b479922ad927
Diffstat (limited to 'meta-openpower/recipes-bsp/ipl')
-rw-r--r--meta-openpower/recipes-bsp/ipl/ipl_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ipl/ipl_git.bb b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
new file mode 100644
index 000000000..edd44bc78
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
@@ -0,0 +1,23 @@
+HOMEPAGE = "https://github.com/open-power/ipl/"
+
+SUMMARY = "Initial Program Load steps"
+DESCRIPTION = "Provides infrastructure to run istep"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git@github.com/open-power/ipl;branch="main""
+SRCREV = "65b394476c6ec40192b6cc44c6722cee5a5bee20"
+
+DEPENDS = " \
+ libekb pdbg autoconf-archive guard \
+ "
+
+RDEPENDS_${PN} = "phal-devtree"
+
+EXTRA_OECONF = "CHIP=p10"