summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
commitbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (patch)
tree00457d3677e86437cec25fd7dab6c4513a53b1a4 /meta-openpower/recipes-bsp/pdata/phal-devtree.bb
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
parentcf6fd27dbd8e2d1b507f8c3752b85801b2c6ef57 (diff)
downloadopenbmc-bb6a14e2f317abf60677c6ad8de9c33d5760bf36.tar.xz
Merge tag '0.63' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openpower/recipes-bsp/pdata/phal-devtree.bb')
-rw-r--r--meta-openpower/recipes-bsp/pdata/phal-devtree.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/pdata/phal-devtree.bb b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
new file mode 100644
index 000000000..4ad477ae4
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Tools and libraries to manage the phal devicetree"
+DESCRIPTION = "phal(power hardware abstraction layer) devicetree data \
+modelling mainly includes the host hardware topology and attributes, \
+which includes the configuration data"
+
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PDATA_DTB_PATH="${datadir}/pdata"
+FILES_${PN} += "${PDATA_DTB_PATH}"
+
+do_install() {
+
+ DTB_FILE_ENV=power-target.sh
+ DTB_FILE_CONF_PATH=${D}${PDATA_DTB_PATH}
+
+ install -d ${DTB_FILE_CONF_PATH}
+ install -m 744 ${THISDIR}/files/${DTB_FILE_ENV} ${DTB_FILE_CONF_PATH}/${DTB_FILE_ENV}
+ install -d ${D}${sysconfdir}/profile.d
+ ln -s ${PDATA_DTB_PATH}/${DTB_FILE_ENV} ${D}${sysconfdir}/profile.d/${DTB_FILE_ENV}
+}