summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-22 22:20:12 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-26 19:14:46 +0300
commit8c561eecb190655d51249c37286cc2c904dee7c0 (patch)
treea489df1bc284965502385f421d7d4f8464f1dfd9 /meta-openpower/recipes-bsp
parent9657ed3a430000aa40231e97d8bcaeb2a88fb247 (diff)
downloadopenbmc-8c561eecb190655d51249c37286cc2c904dee7c0.tar.xz
treewide: clean up recipe checks in OBMC_MACHINE_FEATURES
OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist as all it does is provide a level of indirection to the real MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base). There are a few recipes that have developed checks against OBMC_MACHINE_FEATURES for enabling recipe-level features when they should be checking the standard MACHINE_FEATURES variable. Clean up this recipe-level indirection. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/guard/guard_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-openpower/recipes-bsp/guard/guard_git.bb b/meta-openpower/recipes-bsp/guard/guard_git.bb
index 8208a9cbb..30e7c6b75 100644
--- a/meta-openpower/recipes-bsp/guard/guard_git.bb
+++ b/meta-openpower/recipes-bsp/guard/guard_git.bb
@@ -15,5 +15,5 @@ SRCREV = "ebb9771055a3bb03ed753530870199607559ab63"
DEPENDS = "cli11"
-PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
PACKAGECONFIG[phal] = "-Ddevtree=enabled, -Ddevtree=disabled, pdata pdbg"