summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-17 19:14:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-20 15:50:52 +0300
commitb3fceb33aaa02ca47f8c83d866a69feb6fea6cce (patch)
tree3f7547e319ff9df7dc949bc778d99b9f8f60f3da /meta-openpower/recipes-bsp
parent9fa877fd8ea68fc6cbb3fd3f49643c80a1d7c5d1 (diff)
downloadopenbmc-b3fceb33aaa02ca47f8c83d866a69feb6fea6cce.tar.xz
meta-openpower: croserver: use pythonnative
croservers config script requires python2. Use the yocto built python2 instead of the build host python2, for cases where the build host does not have python2 installed (or env python is python3). (From meta-openpower rev: 1f32015926ead63cea102bbbd67d452e9685f165) Change-Id: I5ef071c141c5b3e3cf2524b5e166bc4891445846 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index e34dba123..376392350 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -5,12 +5,14 @@ LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
SRC_URI = "git://github.com/open-power/eCMD.git"
SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
-DEPENDS += "python-native zlib"
+DEPENDS += "zlib"
SRC_URI += "file://croserver.service"
S = "${WORKDIR}/git"
+inherit pythonnative
+
do_configure() {
LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
}