summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/debug
diff options
context:
space:
mode:
authorShantappa Teekappanavar <sbteeks@yahoo.com>2021-06-22 20:45:28 +0300
committerShantappa Teekappanavar <shantappa.teekappanavar@ibm.com>2021-07-06 21:26:43 +0300
commit6ff8cd80051b7ffdc9927edac7294026aa4bd25c (patch)
treeb73931d3083873cc6eb3d364560b7c61925a2389 /meta-openpower/recipes-phosphor/debug
parent0de4c7f4e9f072fcc29daa7595c74bd4ef3e1cc2 (diff)
downloadopenbmc-6ff8cd80051b7ffdc9927edac7294026aa4bd25c.tar.xz
openpower-debug-collector: Switched to meson build system
The openpower-debug-collector now supports meson build infrastructure to build the binaries. Switching to meson build system instead of using autotools. The enable/disable install_error_yaml is an optional feature used to check the availability of the required packages to build binaries using autotools. In meson build system, this feature is removed since the availability of the packages are always checked, and therefore removing it from the recipe file. Added version bump 222131c to enable meson build support Tested: - Image build: MACHINE=witherspoon-tacoma bitbake obmc-phosphor-image - Updated witherspoon-tacoma BMC with newly created image - Verified watchdog_timeout and checkstop_app are installed at /usr/bin directory Signed-off-by: Shantappa Teekappanavar <sbteeks@yahoo.com> Change-Id: Idc0fc31dbe1e604b4d010590ef18cc5f3638d65b
Diffstat (limited to 'meta-openpower/recipes-phosphor/debug')
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc2
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb22
2 files changed, 2 insertions, 22 deletions
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
index b5f5f78fc..5e946d341 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-debug-collector"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-debug-collector"
-SRCREV = "96f3c8536ba9fae1a3b3050ade03cbd1af416b48"
+SRCREV = "222131cc18135fe80c76aba1c7c91d9c5a80d9c9"
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 505e23255..c4eb9ec32 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -4,8 +4,7 @@ DESCRIPTION = "Application to log error during host checkstop and watchdog timeo
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit autotools \
- pkgconfig \
+inherit meson \
obmc-phosphor-systemd \
python3native \
phosphor-dbus-yaml
@@ -15,7 +14,6 @@ require ${BPN}-systemd-links.inc
DEPENDS += " \
phosphor-logging \
- autoconf-archive-native \
${PYTHON_PN}-sdbus++-native \
"
S = "${WORKDIR}/git"
@@ -34,22 +32,4 @@ DEPENDS_remove_class-native = "phosphor-logging"
# Do not depend on phosphor-logging for native SDK build
DEPENDS_remove_class-nativesdk = "phosphor-logging"
-# Provide a means to enable/disable install_error_yaml feature
-PACKAGECONFIG ??= "install_error_yaml"
-PACKAGECONFIG[install_error_yaml] = " \
- --enable-install_error_yaml, \
- --disable-install_error_yaml, ,\
- "
-
-# Enable install_error_yaml during native and native SDK build
-PACKAGECONFIG_add_class-native = "install_error_yaml"
-PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
-
-# Disable install_error_yaml during target build
-PACKAGECONFIG_remove_class-target = "install_error_yaml"
-
-# Disable generating elog error header file during bitbake. Applications
-# should be using the elog header generated by phosphor-logging recipe
-EXTRA_OECONF += "--disable-gen_errors"
-
BBCLASSEXTEND += "native nativesdk"