summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/debug
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-22 22:20:12 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-26 19:14:46 +0300
commit8c561eecb190655d51249c37286cc2c904dee7c0 (patch)
treea489df1bc284965502385f421d7d4f8464f1dfd9 /meta-openpower/recipes-phosphor/debug
parent9657ed3a430000aa40231e97d8bcaeb2a88fb247 (diff)
downloadopenbmc-8c561eecb190655d51249c37286cc2c904dee7c0.tar.xz
treewide: clean up recipe checks in OBMC_MACHINE_FEATURES
OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist as all it does is provide a level of indirection to the real MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base). There are a few recipes that have developed checks against OBMC_MACHINE_FEATURES for enabling recipe-level features when they should be checking the standard MACHINE_FEATURES variable. Clean up this recipe-level indirection. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
Diffstat (limited to 'meta-openpower/recipes-phosphor/debug')
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc4
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
index 9c522c1cd..b252e6c11 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
@@ -15,7 +15,7 @@ pkg_postinst:${PN}:append() {
TARGET="../openpower-debug-collector-watchdog@.service"
ln -s $TARGET $LINK
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog-timeout@0.service"
TARGET="../openpower-debug-collector-watchdog-timeout@.service"
ln -s $TARGET $LINK
@@ -29,7 +29,7 @@ pkg_prerm:${PN}:append() {
fi
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog@0.service"
rm $LINK
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog-timeout@0.service"
rm $LINK
fi
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 68965af0a..cdb1da621 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -24,7 +24,7 @@ S = "${WORKDIR}/git"
APPS = " \
checkstop \
watchdog \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', '', 'watchdog-timeout', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', '', 'watchdog-timeout', d)} \
"
DEBUG_TMPL = "openpower-debug-collector-{0}@.service"