summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
authorChirag Sharma <chirshar@in.ibm.com>2020-12-11 12:45:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-15 21:53:48 +0300
commit5ec16a36be98bc6a5223319e6cc9d41719b6fb8f (patch)
tree85cc99ef5d1b6cd1b1a0f08c6158c8e35782dd72 /meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
parentd564f2c3efad4338584e70f0af651321a4b8d0e7 (diff)
downloadopenbmc-5ec16a36be98bc6a5223319e6cc9d41719b6fb8f.tar.xz
meta-openpower: Adding proc-pre-poweroff service
Changes: -Adding support for new service i.e. proc-pre-poweroff@.service, which will be called during poweroff. (From meta-openpower rev: 064663fa543eb32bf55f0657a56a3a6cf47bfe0e) Signed-off-by: Chirag Sharma <chirshar@in.ibm.com> Change-Id: I066bb91237f838c87de3da8e10b4d5a4fe7636e8 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 521ff02b9..26e42e2f9 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -52,6 +52,10 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
TARGET="../phal-reinit-devtree.service"
ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
+ TARGET="../proc-pre-poweroff@.service"
+ ln -s $TARGET $LINK
fi
}
@@ -76,5 +80,8 @@ pkg_prerm_${PN}() {
if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
+ rm $LINK
fi
}