summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-06-20 19:46:38 +0300
committerGitHub <noreply@github.com>2019-06-20 19:46:38 +0300
commit43a183cc0926da36e3a218efa02ab4838ace316f (patch)
tree9ea192b408585fc2a19b54d196c3d56eaddc4acb /meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
parent5575b1d27fc222f973d96dc06af0f21ba7656f28 (diff)
parent2c7e8f4ce61f2e0407c37e98e22bbb13e562b414 (diff)
downloadopenbmc-43a183cc0926da36e3a218efa02ab4838ace316f.tar.xz
Merge pull request #12 from Intel-BMC/update
Update
Diffstat (limited to 'meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb')
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
new file mode 100644
index 000000000..1e9fdd66f
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Init BMC Hostname"
+DESCRIPTION = "Setup BMC Unique hostname"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch systemd
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+
+SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
+
+SRC_URI = "file://${PN}.sh file://${PN}.service"
+
+S = "${WORKDIR}"
+do_install() {
+ sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
+ install -d ${D}${bindir} ${D}${systemd_system_unitdir}
+ install ${PN}.sh ${D}${bindir}/
+ install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
+}
+