summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 20:35:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commit8c6707f0dcab30d2c0d818b455b030b5d7e7091c (patch)
treee6d72dfc25e2769c7c6ea93c064af0970d8f3c7e /meta-openpower/recipes-phosphor/occ
parentf3acf6db3a6e527a4c8347643924fbc33c65e237 (diff)
downloadopenbmc-8c6707f0dcab30d2c0d818b455b030b5d7e7091c.tar.xz
meta-openpower: prep for new override syntax
Change-Id: I5ca16c6fa7bc616bfa9bc41c4f86d32fd92b0287 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb2
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb24
2 files changed, 13 insertions, 13 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
index db9ce5d5e..f546355e5 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
@@ -11,7 +11,7 @@ PROVIDES += "virtual/openpower-occ-control-config-native"
DEPENDS += "mrw-native mrw-perl-tools-native"
# Generate a YAML files based on MRW input
-do_install_append() {
+do_install:append() {
install -d ${YAML_DEST}/
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 210b5fcc2..02237b008 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -13,15 +13,15 @@ inherit autotools \
require ${BPN}.inc
SRC_URI += "file://occ-active.sh"
-do_install_append() {
+do_install:append() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/occ-active.sh \
${D}${bindir}/occ-active.sh
}
DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-enable@.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-enable@.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
@@ -37,13 +37,13 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
EXTRA_OECONF = " \
YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
"
-EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
+EXTRA_OECONF:append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
OCC_ENABLE = "enable"
OCC_DISABLE = "disable"
@@ -71,22 +71,22 @@ SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS'
S = "${WORKDIR}/git"
# Remove packages not required for native build
-DEPENDS_remove_class-native = " \
+DEPENDS:remove:class-native = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-native += "phosphor-state-manager-obmc-targets"
# Remove packages not required for native SDK build
-DEPENDS_remove_class-nativesdk = " \
+DEPENDS:remove:class-nativesdk = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-nativesdk += "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"
@@ -97,10 +97,10 @@ PACKAGECONFIG[install_error_yaml] = "\
"
# Enable install_error_yaml during native and native SDK build
-PACKAGECONFIG_add_class-native = "install_error_yaml"
-PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
+PACKAGECONFIG:add:class-native = "install_error_yaml"
+PACKAGECONFIG:add:class-nativesdk = "install_error_yaml"
# Disable install_error_yaml during target build
-PACKAGECONFIG_remove_class-target = "install_error_yaml"
+PACKAGECONFIG:remove:class-target = "install_error_yaml"
BBCLASSEXTEND += "native nativesdk"