summaryrefslogtreecommitdiff
path: root/meta-phosphor/aspeed-layer/recipes-kernel
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2021-03-31 04:35:52 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-06 16:53:47 +0300
commit67fed83348e6e6fbd5a08ea57fe885bd3c51bf99 (patch)
treef0b0d565e85525bf3121b4b3fd03affc24f0c055 /meta-phosphor/aspeed-layer/recipes-kernel
parentc2a772f7b816166ee0965e98649a66d87045ccc8 (diff)
downloadopenbmc-67fed83348e6e6fbd5a08ea57fe885bd3c51bf99.tar.xz
phosphor: Remove phosphor-vlan machine feature
This feature is used to turn on the CONFIG_VLAN_8021Q kernel option for all systems using the phosphor layer. However, the kernel option has been enabled in the defconfigs for aspeed g4, g5, g6, and nuvoton via gbs, and gxp. Drop the feature and subseqently remove KERNEL_DANGLING_FEATURES_WARN_ONLY. Change-Id: I544cb5ba8e74f1217f90cc1eaccf725beb32bd3b Signed-off-by: Joel Stanley <joel@jms.id.au>
Diffstat (limited to 'meta-phosphor/aspeed-layer/recipes-kernel')
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg1
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc2
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend11
3 files changed, 0 insertions, 14 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg
deleted file mode 100644
index 1ea3eed08..000000000
--- a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_VLAN_8021Q=y
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc
deleted file mode 100644
index 46d3bcec8..000000000
--- a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc
+++ /dev/null
@@ -1,2 +0,0 @@
-define KFEATURE_DESCRIPTION "Enable VLAN support"
-kconf non-hardware phosphor-vlan.cfg
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
deleted file mode 100644
index d8bbccfac..000000000
--- a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://phosphor-vlan.scc"
-SRC_URI += "file://phosphor-vlan.cfg"
-
-KERNEL_FEATURES_append = " phosphor-vlan"
-KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"
-
-# OpenBMC loads in kernel features via other mechanisms so this check
-# in the kernel-yocto.bbclass is not required
-KERNEL_DANGLING_FEATURES_WARN_ONLY="1"