summaryrefslogtreecommitdiff
path: root/meta-phosphor/aspeed-layer
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-08-27 02:18:24 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-01 03:26:22 +0300
commitf021ee9f72d43f6033e033ce244e542fb74c62db (patch)
treec72297843502ebadb5ba69a29a9bb61a4c7ddb97 /meta-phosphor/aspeed-layer
parent263e52a2e679ade9765ab72fbb01e4ac9e70f843 (diff)
downloadopenbmc-f021ee9f72d43f6033e033ce244e542fb74c62db.tar.xz
kernel: enable KERNEL_DANGLING_FEATURES_WARN_ONLY
Uptream yocto recently added some new code which enforces kernel feature validation. The commit which did this is: https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=095175595d9f28d5a0eb7ea520c9af0100bb8dfd This caused OpenBMC builds to start failing with the following: | ERROR: Feature 'phosphor-wdt-on-panic' not found, this will cause configuration failures. | ERROR: Check the SRC_URI for meta-data repositories or directories that may be missing | ERROR: Set KERNEL_DANGLING_FEATURES_WARN_ONLY to ignore this issue OpenBMC does not utilize this aspect of the kernel-yocto.bbclass so make it a warning only. Tested: Verified that the resultant build still had the expected CONFIG options set in the linux-aspeed defconfig. Resolves openbmc/openbmc#3690 (From meta-phosphor rev: d9a065db400bea4b026e240532dd369e588c967d) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I7590e6304307599cbc77ef26ca9708a70d47d8a0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/aspeed-layer')
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
index ea70a4fe8..6acd6a6e1 100644
--- a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -9,3 +9,10 @@ SRC_URI += "file://phosphor-wdt-on-panic.cfg"
KERNEL_FEATURES_append = " phosphor-vlan"
KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"
+
+python () {
+ # OpenBMC loads in kernel features via other mechanisms so this check
+ # in the kernel-yocto.bbclass is not required
+ d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
+}
+