summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-core
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2018-01-10 18:16:28 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-01 17:19:14 +0300
commit253a5aa905bf3298817377d199becec9755cebf8 (patch)
tree0dae65be828864b06425d01e1e4d3817846f5d39 /meta-phosphor/common/recipes-core
parenta304468028c34ef846130679b09b8e99f0e61761 (diff)
downloadopenbmc-253a5aa905bf3298817377d199becec9755cebf8.tar.xz
Keep fan services running until poweroff completes
All the fan services associated with controlling, monitoring and presence detection of fans need to remain active until a poweroff completes. This helps ensure thermal safety while a system is in transition to a powered off state. With the introduction of this new target (which runs last in the power off path), need to move the host reset service to running after it to ensure the power on in the reboot path does not start until the last power off target runs. Resolves openbmc/openbmc#2762 Change-Id: I4ca671d2c7de66e8bfa4bba607b06c88c0a6e7f9 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-core')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets.bb3
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-powered-off@.target9
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-fan-control-ready@.target2
3 files changed, 12 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
index 10614701d..26fbcd1f6 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
@@ -18,9 +18,10 @@ CHASSIS_SYNCH_TARGETS = "start-pre start on stop-pre stop off reset-on"
# Chassis action power targets
# - on: Services to run to power on the chassis
# - off: Services to run to power off the chassis
+# - powered-off: Services to run once chassis power is off
# - reset: Services to check chassis power state and update chassis "on" target
# - hard-off: Services to force an immediate power off of the chassis
-CHASSIS_ACTION_TARGETS = "poweron poweroff powerreset hard-poweroff"
+CHASSIS_ACTION_TARGETS = "poweron poweroff powered-off powerreset hard-poweroff"
# Track all host synchronization point targets
# - start-pre: Services to run before we start host boot
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-powered-off@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-powered-off@.target
new file mode 100644
index 000000000..1a042a0b8
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-powered-off@.target
@@ -0,0 +1,9 @@
+[Unit]
+Description=Chassis%i (Powered Off)
+Wants={SYSTEMD_DEFAULT_TARGET}
+After={SYSTEMD_DEFAULT_TARGET}
+Wants=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
+After=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
+Conflicts=obmc-chassis-poweron@%i.target
+Conflicts=obmc-chassis-reset@%i.target
+RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-fan-control-ready@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-fan-control-ready@.target
index 6957b1b93..e041a5508 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-fan-control-ready@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-fan-control-ready@.target
@@ -1,4 +1,4 @@
[Unit]
Description=Fan Control Ready
RefuseManualStop=yes
-Conflicts=obmc-chassis-poweroff@%i.target
+Conflicts=obmc-chassis-powered-off@%i.target