summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-core
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-01-30 04:53:51 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-02-10 19:08:22 +0300
commit51402c190e66aafaad4cfc885a01651ec524aaac (patch)
tree324a91992e73cc4db389e62056089803c3be35c1 /meta-phosphor/common/recipes-core
parent385287cd8301f16703e0c8dc971447f1f520e4bb (diff)
downloadopenbmc-51402c190e66aafaad4cfc885a01651ec524aaac.tar.xz
System quiesce target for when required targets fail
This will be the target that all other critical targets go to when a service within it fails. Automated recovery and stay-in-fail-state logic will be built on top of entry into this new target. Change-Id: Ibdf2e823cf372916c61ef5a8375c4faf8a928119 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-core')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets.bb2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target6
2 files changed, 7 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
index 4317037ed..5f34c17be 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
@@ -16,7 +16,7 @@ CHASSIS_POWER_TARGETS = "on off"
# Track all host synchronization point target
HOST_SYNCH_TARGETS = "start-pre start started stop-pre stop stopped"
# Track all host action targets
-HOST_ACTION_TARGETS = "stop"
+HOST_ACTION_TARGETS = "stop quiesce"
CHASSIS_FMT = "obmc-chassis-{0}@.target"
SYNCH_POWER_FMT = "obmc-power-{0}@.target"
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target
new file mode 100644
index 000000000..d0473b091
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target
@@ -0,0 +1,6 @@
+[Unit]
+Description=Quiesce Target
+Wants={SYSTEMD_DEFAULT_TARGET}
+After={SYSTEMD_DEFAULT_TARGET}
+RefuseManualStop=yes
+Conflicts=obmc-power-chassis-off@%i.target