summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-16 14:32:12 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-16 21:55:10 +0300
commit1f09d4ae2aa35b469578ff284c98579d23cdac4d (patch)
treee414ee93b46a54a493a17551ae1fda2a1968c009 /meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
parent3aa591fe9b9509fbdb0ea41ae6763448393294ac (diff)
downloadopenbmc-1f09d4ae2aa35b469578ff284c98579d23cdac4d.tar.xz
Add virtual/phosphor-logging-callouts
This virtual generates mappings between sysfs device paths and inventory items. Add a native recipe that builds the configuration from MRW. Set this recipe as the default for OpenPOWER systems. Resolves openbmc/openbmc#1093 Resolves openbmc/openbmc#1249 Change-Id: If67b4ef0850910a076ca212197a4bd0e704d0266 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
new file mode 100644
index 000000000..f76d202e1
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Generated callout information for phosphor-logging"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-logging
+
+SRC_URI += "file://callouts.yaml"
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${callouts_datadir}
+ install -d ${DEST}
+ install callouts.yaml ${DEST}
+}