summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-support
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2018-07-30 20:59:30 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 03:27:25 +0300
commit5145ab10812c1187b06e8dfb510f323d6958f8b0 (patch)
tree583a2e8a1799becfdaab2b5c566c5a043bc7e3fb /meta-phosphor/common/recipes-support
parent41b334a287d01f4076e79bda549db347e64a8642 (diff)
downloadopenbmc-5145ab10812c1187b06e8dfb510f323d6958f8b0.tar.xz
Add cjson recipe
CJson is a support library implementing json support for C libraries. It is relatively small, and compliant enough for secure systems usage. More information can be found in the CJson homepage here: https://github.com/DaveGamble/cJSON Tested by: "bitbake cjson" and saw no build failures. (From meta-phosphor rev: 908d4f44184e34e0d13e6017221122ab5915a310) Change-Id: I8b9fcbc5ce0ffe556da8bfa6b1d84c527160a65e Signed-off-by: Ed Tanous <ed.tanous@intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-support')
-rw-r--r--meta-phosphor/common/recipes-support/cjson/cjson_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-support/cjson/cjson_git.bb b/meta-phosphor/common/recipes-support/cjson/cjson_git.bb
new file mode 100644
index 000000000..096e3c988
--- /dev/null
+++ b/meta-phosphor/common/recipes-support/cjson/cjson_git.bb
@@ -0,0 +1,15 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git"
+
+PV = "1.7.6+git${SRCPV}"
+SRCREV = "cbc05de76fbd4dfff17b5626d5cfe9ec922b1f4a"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN}-dev += "${libdir}/cmake/cJSON/*"
+
+EXTRA_OECMAKE = "-DENABLE_CUSTOM_COMPILER_FLAGS=OFF -DENABLE_TARGET_EXPORT=OFF"