summaryrefslogtreecommitdiff
path: root/meta-phosphor/conf
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/conf
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/conf')
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-base.inc14
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc10
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-mrw.inc20
-rw-r--r--meta-phosphor/conf/layer.conf4
-rw-r--r--meta-phosphor/conf/local.conf.sample8
-rw-r--r--meta-phosphor/conf/machine/include/obmc-bsp-common.inc2
6 files changed, 29 insertions, 29 deletions
diff --git a/meta-phosphor/conf/distro/include/phosphor-base.inc b/meta-phosphor/conf/distro/include/phosphor-base.inc
index e42c8c20d..45f27a7df 100644
--- a/meta-phosphor/conf/distro/include/phosphor-base.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-base.inc
@@ -62,8 +62,8 @@ OELAYOUT_ABI = "12"
WARN_TO_ERROR_QA = "already-stripped compile-host-path install-host-path \
installed-vs-shipped ldflags pn-overrides rpaths staticdev \
useless-rpaths"
-WARN_QA_remove = "${WARN_TO_ERROR_QA}"
-ERROR_QA_append = " ${WARN_TO_ERROR_QA}"
+WARN_QA:remove = "${WARN_TO_ERROR_QA}"
+ERROR_QA:append = " ${WARN_TO_ERROR_QA}"
require conf/distro/include/no-static-libs.inc
require conf/distro/include/yocto-uninative.inc
@@ -112,14 +112,14 @@ MACHINE_FEATURES += " \
${OBMC_MACHINE_FEATURES} \
"
-DISTRO_EXTRA_RDEPENDS_remove_qemuarm = "packagegroup-core-device-devel"
+DISTRO_EXTRA_RDEPENDS:remove:qemuarm = "packagegroup-core-device-devel"
include conf/distro/include/openbmc-phosphor/${MACHINE}.inc
-IMAGE_CLASSES_append = " image_types_phosphor phosphor-rootfs-postcommands"
-IMAGE_CLASSES_append_npcm7xx = " image_types_phosphor_nuvoton"
+IMAGE_CLASSES:append = " image_types_phosphor phosphor-rootfs-postcommands"
+IMAGE_CLASSES:append:npcm7xx = " image_types_phosphor_nuvoton"
-IMAGE_INSTALL_append = " dbus-broker libnss-systemd"
+IMAGE_INSTALL:append = " dbus-broker libnss-systemd"
# Skip the udev database by default. It adds around 2MB
# compressed to the root filesystem, and probably doesn't
@@ -129,7 +129,7 @@ BAD_RECOMMENDATIONS += "shared-mime-info"
LAYER_CONF_VERSION ?= "8"
-KERNEL_CLASSES_append = " obmc-phosphor-kernel-version"
+KERNEL_CLASSES:append = " obmc-phosphor-kernel-version"
# Some packages have directory trees of YAML files arranged based on
# canonical organization names. 'xyz/openbmc_project' should be used
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index 63aee78dc..8673a15c1 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -231,16 +231,16 @@ require conf/distro/include/security_flags.inc
# Disable security on croserver.
# Remove if https://github.com/open-power/eCMD/pull/433 is ever merged
-SECURITY_STRINGFORMAT_pn-croserver = ""
+SECURITY_STRINGFORMAT:pn-croserver = ""
# obmc-libobmc-intf doesn't compile with security flags enabled
-SECURITY_CFLAGS_pn-obmc-libobmc-intf = ""
+SECURITY_CFLAGS:pn-obmc-libobmc-intf = ""
# remove when https://gerrit.openbmc-project.xyz/c/openbmc/pldm/+/39984
# is merged and rev bumped
-SECURITY_CFLAGS_pn-pldm = ""
+SECURITY_CFLAGS:pn-pldm = ""
# We generally want to enable LTO with meson
-EXTRA_OEMESON_append_class-target = " -Db_lto=true"
+EXTRA_OEMESON:append:class-target = " -Db_lto=true"
# Set the root password to '0penBmc'
# Override this in your local.conf
@@ -250,6 +250,6 @@ inherit extrausers
# salted and hashed with SHA512 suitable for /etc/shadow or `usermod -p`.
DEFAULT_OPENBMC_PASSWORD = "'\$6\$UGMqyqdG\$GqTb3tXPFx9AJlzTw/8X5RoW2Z.100dT.acuk8AFJfNQYr.ZRL8itMIgLqsdq46RNHgiv78XayOSl.IbR4DFU.'"
-EXTRA_USERS_PARAMS_pn-obmc-phosphor-image = " \
+EXTRA_USERS_PARAMS:pn-obmc-phosphor-image = " \
usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \
"
diff --git a/meta-phosphor/conf/distro/include/phosphor-mrw.inc b/meta-phosphor/conf/distro/include/phosphor-mrw.inc
index 9fe8618a4..56e0d015c 100644
--- a/meta-phosphor/conf/distro/include/phosphor-mrw.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-mrw.inc
@@ -4,14 +4,14 @@ DISTRO_FEATURES_FILTER_NATIVESDK += "obmc-mrw"
DISTROOVERRIDES .= ":df-mrw"
-VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw ?= "phosphor-hwmon-config-mrw"
+VIRTUAL-RUNTIME_phosphor-hwmon-config:df-mrw ?= "phosphor-hwmon-config-mrw"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory_df-mrw ?= "phosphor-ipmi-fru-inventory-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-properties_df-mrw ?= "phosphor-ipmi-fru-properties-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-read-inventory_df-mrw ?= "phosphor-ipmi-fru-read-inventory-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory_df-mrw ?= "phosphor-ipmi-sensor-inventory-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-inventory-sel_df-mrw ?= "phosphor-ipmi-inventory-sel-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native_df-mrw ?= "phosphor-led-manager-config-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-logging-callouts_df-mrw ?= "phosphor-logging-callouts-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw ?= "phosphor-fan-presence-mrw"
-PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw ?= "phosphor-fan-control-fan-config-mrw"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory:df-mrw ?= "phosphor-ipmi-fru-inventory-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-properties:df-mrw ?= "phosphor-ipmi-fru-properties-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-read-inventory:df-mrw ?= "phosphor-ipmi-fru-read-inventory-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory:df-mrw ?= "phosphor-ipmi-sensor-inventory-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-inventory-sel:df-mrw ?= "phosphor-ipmi-inventory-sel-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native:df-mrw ?= "phosphor-led-manager-config-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-logging-callouts:df-mrw ?= "phosphor-logging-callouts-mrw-native"
+PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config:df-mrw ?= "phosphor-fan-presence-mrw"
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config:df-mrw ?= "phosphor-fan-control-fan-config-mrw"
diff --git a/meta-phosphor/conf/layer.conf b/meta-phosphor/conf/layer.conf
index f651b2d1b..664fc0e40 100644
--- a/meta-phosphor/conf/layer.conf
+++ b/meta-phosphor/conf/layer.conf
@@ -7,8 +7,8 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "phosphor-layer"
BBFILE_PATTERN_phosphor-layer := "^${LAYERDIR}/"
-LAYERVERSION_phosphor-layer = "1"
-LAYERSERIES_COMPAT_phosphor-layer = "gatesgarth hardknott"
+LAYERVERSION:phosphor-layer = "1"
+LAYERSERIES_COMPAT_phosphor-layer = "gatesgarth hardknott honister"
IMAGE_FEATURES[validitems] += "tools-profile"
diff --git a/meta-phosphor/conf/local.conf.sample b/meta-phosphor/conf/local.conf.sample
index 0a6216329..a3853679c 100644
--- a/meta-phosphor/conf/local.conf.sample
+++ b/meta-phosphor/conf/local.conf.sample
@@ -1,11 +1,11 @@
MACHINE ??= "qemuarm"
DISTRO ?= "openbmc-phosphor"
PACKAGE_CLASSES ?= "package_rpm"
-SANITY_TESTED_DISTROS_append ?= " *"
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
-USER_CLASSES ?= "buildstats image-prelink"
+SANITY_TESTED_DISTROS:append ?= " *"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
+USER_CLASSES ?= "buildstats"
PATCHRESOLVE = "noop"
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
diff --git a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
index 8a3da1199..158c569f4 100644
--- a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
+++ b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
@@ -26,4 +26,4 @@ IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', \
INITRAMFS_CTYPE ?= "xz"
INITRAMFS_FSTYPES = "cpio.${INITRAMFS_CTYPE}"
INITRAMFS_IMAGE = "obmc-phosphor-initramfs"
-INITRAMFS_IMAGE_df-obmc-ubi-fs = ""
+INITRAMFS_IMAGE:df-obmc-ubi-fs = ""