summaryrefslogtreecommitdiff
path: root/meta-phosphor/nuvoton-layer
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-09-01 18:25:32 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-01 22:09:43 +0300
commit32cc5c1f5be9b95ed6ae62eb76f5f06afbd18805 (patch)
tree33e0b2e9c0a458092d103efc1ea619c51b9009a6 /meta-phosphor/nuvoton-layer
parent1ee6bb5418787ac573e6f6edaccc99cfd11edeea (diff)
downloadopenbmc-32cc5c1f5be9b95ed6ae62eb76f5f06afbd18805.tar.xz
nuvoton: enable KERNEL_DANGLING_FEATURES_WARN_ONLY
Uptream yocto recently added some new code which enforces kernel feature validation. The commit which did this is: https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=095175595d9f28d5a0eb7ea520c9af0100bb8dfd This caused OpenBMC builds to start failing with the following: | ERROR: Feature 'phosphor-gpio-keys' not found, this will cause configuration failures. | ERROR: Check the SRC_URI for meta-data repositories or directories that may be missing | ERROR: Set KERNEL_DANGLING_FEATURES_WARN_ONLY to ignore this issue OpenBMC does not utilize this aspect of the kernel-yocto.bbclass so make it a warning only. Tested: Verified that the resultant build still had the expected CONFIG options set in the linux-nuvoton .config file See openbmc/openbmc#3690 (From meta-phosphor rev: 75a6424eec93729fd40154413b1a350b9f10fe8b) Change-Id: I12bf3857601f186300d3b1c56c490be6e6582dda Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/nuvoton-layer')
-rw-r--r--meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend b/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
index 71e208cd4..88b386018 100644
--- a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
+++ b/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
@@ -2,3 +2,11 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://phosphor-gpio-keys.scc"
SRC_URI += "file://phosphor-gpio-keys.cfg"
+
+
+python () {
+ # OpenBMC loads in kernel features via other mechanisms so this check
+ # in the kernel-yocto.bbclass is not required
+ d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
+}
+