summaryrefslogtreecommitdiff
path: root/meta-phosphor/nuvoton-layer
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-09-17 04:29:53 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-25 03:03:03 +0300
commit7a6b143d9b30f8f4a24cf7cd17b2cb1df39002a2 (patch)
tree6468ae94f3c1f8c377f16a33c82564077cd16598 /meta-phosphor/nuvoton-layer
parent727155e89fd50393b6444d182ac8fab4309e6b2a (diff)
downloadopenbmc-7a6b143d9b30f8f4a24cf7cd17b2cb1df39002a2.tar.xz
nuvoton: Apply image overrides to all image types
Right now, nuvoton overrides needed for generating and applying the bootblock are not applied to images other than obmc-phosphor-image. This means that core-image-minimal is unbootable on nuvoton platforms. This change makes the nuvoton overrides apply globally to all images. (From meta-phosphor rev: 9819cb9533f430797d47dadff558cf4462670976) Change-Id: If4bef5f8106278fa6ebeb2198bc43fdd2b70a641 Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/nuvoton-layer')
-rw-r--r--meta-phosphor/nuvoton-layer/recipes-phosphor/images/obmc-phosphor-image.bbappend70
1 files changed, 0 insertions, 70 deletions
diff --git a/meta-phosphor/nuvoton-layer/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-phosphor/nuvoton-layer/recipes-phosphor/images/obmc-phosphor-image.bbappend
deleted file mode 100644
index e60401e89..000000000
--- a/meta-phosphor/nuvoton-layer/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ /dev/null
@@ -1,70 +0,0 @@
-EXTRA_DEPENDS = ""
-
-EXTRA_DEPENDS_npcm7xx = " \
- npcm7xx-bootblock:do_deploy \
- npcm7xx-bingo-native:do_populate_sysroot \
- "
-
-UBOOT_BINARY := "u-boot.${UBOOT_SUFFIX}"
-
-BOOTBLOCK = "Poleg_bootblock.bin"
-
-
-FULL_SUFFIX = "full"
-MERGED_SUFFIX = "merged"
-
-UBOOT_SUFFIX_append_npcm7xx = ".${MERGED_SUFFIX}"
-
-
-do_prepare_bootloaders() {
-
-}
-
-
-# Prepare the Bootblock and U-Boot images using npcm7xx-bingo
-
-do_prepare_bootloaders_npcm7xx() {
-
- currdir=`pwd`
- cd ${DEPLOY_DIR_IMAGE}
-
- bingo ${STAGING_DIR_NATIVE}/${bindir}/BootBlockAndHeader_EB.xml \
- -o ${DEPLOY_DIR_IMAGE}/${BOOTBLOCK}.${FULL_SUFFIX}
-
- bingo ${STAGING_DIR_NATIVE}/${bindir}/UbootHeader_EB.xml \
- -o ${DEPLOY_DIR_IMAGE}/${UBOOT_BINARY}.${FULL_SUFFIX}
-
- bingo ${STAGING_DIR_NATIVE}/${bindir}/mergedBootBlockAndUboot.xml \
- -o ${DEPLOY_DIR_IMAGE}/${UBOOT_BINARY}.${MERGED_SUFFIX}
-
- cd $currdir
-}
-
-
-do_prepare_bootloaders[depends] += "${EXTRA_DEPENDS}"
-
-
-addtask do_prepare_bootloaders before do_generate_static after do_generate_rwfs_static
-
-
-# Include the full bootblock and u-boot in the final static image
-
-python do_generate_static_append_npcm7xx() {
-
- _append_image(os.path.join(d.getVar('DEPLOY_DIR_IMAGE', True),
- 'u-boot.%s' % d.getVar('UBOOT_SUFFIX',True)),
- int(d.getVar('FLASH_UBOOT_OFFSET', True)),
- int(d.getVar('FLASH_KERNEL_OFFSET', True)))
-}
-
-do_make_ubi_append_npcm7xx() {
-
- # Concatenate the uboot and ubi partitions
- dd bs=1k conv=notrunc seek=${FLASH_UBOOT_OFFSET} \
- if=${DEPLOY_DIR_IMAGE}/u-boot.${UBOOT_SUFFIX} \
- of=${IMGDEPLOYDIR}/${IMAGE_NAME}.ubi.mtd
-}
-
-do_make_ubi[depends] += "${PN}:do_prepare_bootloaders"
-do_generate_ubi_tar[depends] += "${PN}:do_prepare_bootloaders"
-do_generate_static_tar[depends] += "${PN}:do_prepare_bootloaders"