summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
diff options
context:
space:
mode:
authorraviteja-b <raviteja28031990@gmail.com>2019-09-25 14:00:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-17 03:33:49 +0300
commit170f12bd2255304fd691663d8d4c6bc2aa0195ef (patch)
treec7d5ad707d9f9fc3a16c82f9095a3f055e8baca8 /meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
parent3272f92b6b0c157dec1e30b1a96588602736f208 (diff)
downloadopenbmc-170f12bd2255304fd691663d8d4c6bc2aa0195ef.tar.xz
Avahi:Fix to check and create avahi group and user before starting avahi service.
Avahi service fails to start when we code update from image which has no avahi service to image which has avahi service,As part of code update. we don't touch the persistent file(/etc/group or /etc/password). Now the image which is going to be updated needs these persistent files to be updated. I have tried to add avahi user using extrausers and pkg_postinst scripts I could see updated /etc/group and /etc/password files with avahi entry in rootfs build directory, but after code update to this new BMC image we dont see these udpated files on the system, where as this new image requires avahi user and the group to be present in the /etc/passwd and /etc/group on the system. Implemented service override file to check and create avahi group and user before starting avahi service. Tested By: 1.Code updating images 2.Reboot (From meta-phosphor rev: edf3b2a313b4f21e97ffbb09d10fae7133ab58b7) Signed-off-by: Ravi Teja <raviteja28031990@gmail.com> Change-Id: I6b4947f1776d64f7aa0eeb79fb0453f1fdfc825d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend')
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
new file mode 100644
index 000000000..ee15899fa
--- /dev/null
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/avahi-daemon:"
+
+SRC_URI += "file://avahi-daemon-override.conf"
+
+FILES_avahi-daemon_append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
+
+do_install_append() {
+
+ install -m 644 -D ${WORKDIR}/avahi-daemon-override.conf \
+ ${D}${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf
+}