summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorAnton D. Kachalov <gmouse@google.com>2021-02-04 15:13:57 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-12 23:11:13 +0300
commit23e749b62bb4c541d19cf3b79611d9d40cb215e1 (patch)
treef714bb8cd7ebdd8f1fdfd917def5d3b1ef9a810a /meta-phosphor/recipes-core
parent57e15b1d5cf7749e6bd01c3ef484689f4191d51e (diff)
downloadopenbmc-23e749b62bb4c541d19cf3b79611d9d40cb215e1.tar.xz
Enable Systemd NSS module to support DynamicUsers
DynamicUsers flag in systemd service configuration file required to create, handle and recycle temporary users. This is essential module for upcoming daemons' privilege separation work. Reference: https://github.com/openbmc/openbmc/issues/3383 Signed-off-by: Anton D. Kachalov <gmouse@google.com> Change-Id: Iabd709c4a20f754fc6ea505e640b2d361aba0be2
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/base-files/base-files_%.bbappend2
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend1
2 files changed, 3 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/base-files/base-files_%.bbappend b/meta-phosphor/recipes-core/base-files/base-files_%.bbappend
index b6c4222b2..30e562325 100644
--- a/meta-phosphor/recipes-core/base-files/base-files_%.bbappend
+++ b/meta-phosphor/recipes-core/base-files/base-files_%.bbappend
@@ -10,6 +10,8 @@ SRC_URI += " \
"
do_install_append() {
+ sed -i 's/\(\(passwd\|group\):\s*\).*/\1files systemd/' \
+ "${D}${sysconfdir}/nsswitch.conf"
install -d ${D}/srv
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index f1046de20..1f0b95e39 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -6,6 +6,7 @@ PACKAGECONFIG = "\
hostnamed \
kmod \
networkd \
+ nss \
pam \
randomseed \
resolved \