summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-10 01:03:57 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-11 01:54:14 +0300
commit61b3b69043ad582ac23dd1c3fe6d7ab285bb0b4c (patch)
tree5166198f9c1ee869d6112bc89784bb173b7574ca /meta-phosphor/recipes-core
parentc2008faffdeccf1185c3e5530e40f8d69e366dde (diff)
downloadopenbmc-61b3b69043ad582ac23dd1c3fe6d7ab285bb0b4c.tar.xz
meta-phosphor: systemd: fix file search paths
Typically it does not make any sense to append to FILESEXTRAPATHS. FILESEXTRAPATHS is set in a bbappend when overriding something from another layer. The typical desire will be to make bitbake search for files in the layer with the bbappend and not some other layer earlier in the priority list. Further, appending to FILESEXTRAPATHS will introduce unexpected behavior when multiple layers append the same recipe - layers with higher layer priorities that append to FILESEXTRAPATHS will find their files overriden by files in layers with lower priorities. (From meta-phosphor rev: 3b1f826a641ec83dbc67214912f093e9eb0147eb) Change-Id: I69549d14397fe6a33ca7113616665481ff143435 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index e1067f0e5..f9d830157 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -4,7 +4,7 @@ PACKAGES =+ "${PN}-catalog-extralocales"
PACKAGECONFIG = "pam hostnamed networkd randomseed resolved sysusers timedated \
timesyncd xz"
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://default.network"
SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"