summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-05-02 14:20:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-14 01:09:11 +0300
commita937d1012f362e3622e22d19cf6b945186e6185e (patch)
treee3a83700c0926fe3251a7568867614d98279c478 /meta-phosphor/recipes-core
parent556e23b33ab210386e5f1ad891b8c0240c15967d (diff)
downloadopenbmc-a937d1012f362e3622e22d19cf6b945186e6185e.tar.xz
systemd: remove default.network
Yocto now installs a file 80-wired.network[1] which contains the same information as the 'default.network' except that it also enables IPv6 dhcp. Remove the 'default.network' in our bbappend since it is redundant. Any configuration created by phosphor-networkd is created as 00-bmc-*.network, which will take precedence lexigraphically over this 80-wired.network default. 1. https://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-core/systemd/systemd-conf_244.3.bb?h=dunfell#n20 (From meta-phosphor rev: 8666e2b0746f8b180e90c252c7688daf9d7c0b89) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Iecaeb8ad74e8c1dfe4e9832ca18c1b3193c507f0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd/default.network4
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend6
2 files changed, 0 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-core/systemd/systemd/default.network b/meta-phosphor/recipes-core/systemd/systemd/default.network
deleted file mode 100644
index c75c3d60d..000000000
--- a/meta-phosphor/recipes-core/systemd/systemd/default.network
+++ /dev/null
@@ -1,4 +0,0 @@
-[Match]
-Name=eth*
-[Network]
-DHCP=ipv4
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index ee9c11a49..1aabe378f 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -17,16 +17,10 @@ PACKAGECONFIG = "\
"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://default.network"
SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
-FILES_${PN} += "${systemd_unitdir}/network/default.network"
EXTRA_OEMESON += "-Ddns-servers=''"
-do_install_append() {
- install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
-}
-
ALTERNATIVE_${PN} += "init"
ALTERNATIVE_TARGET[init] = "${rootlibexecdir}/systemd/systemd"
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"