summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-12-17 22:46:13 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-05 18:53:16 +0300
commitcf61a68053da9531100618eb06a0ba5d016238a2 (patch)
tree9c36023a3c0b1f1a08bc745725d752b6a7559db7 /meta-phosphor/recipes-core
parent58c4886c6077d6b1e70be7ae38b25537963ae781 (diff)
downloadopenbmc-cf61a68053da9531100618eb06a0ba5d016238a2.tar.xz
busybox: enable less options for systemd
There are a number of options that make busybox-less work better with systemd's pager expectations. Add them in. Also, add in a few options for usability. (From meta-phosphor rev: 70fd77661f452d5982330da2db2c8e26edee2c58) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I331654f9db6918c6c4a3c13f94ce638a08e934af Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/busybox/busybox/less.cfg10
-rw-r--r--meta-phosphor/recipes-core/busybox/busybox_%.bbappend1
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/busybox/busybox/less.cfg b/meta-phosphor/recipes-core/busybox/busybox/less.cfg
new file mode 100644
index 000000000..2b452279b
--- /dev/null
+++ b/meta-phosphor/recipes-core/busybox/busybox/less.cfg
@@ -0,0 +1,10 @@
+## In orer to make systemd-pager work well there are a number of busybox less
+## features we need to enable.
+CONFIG_FEATURE_LESS_DASHCMD=y
+CONFIG_FEATURE_LESS_RAW=y
+CONFIG_FEATURE_LESS_ENV=y
+
+## These are nice features for users.
+CONFIG_FEATURE_LESS_WINCH=y
+CONFIG_FEATURE_LESS_ASK_TERMINAL=y
+CONFIG_FEATURE_LESS_REGEXP=y
diff --git a/meta-phosphor/recipes-core/busybox/busybox_%.bbappend b/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
index 8907b08e0..9433b5c33 100644
--- a/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
@@ -1,5 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://busybox.cfg"
SRC_URI += "file://flash.cfg"
+SRC_URI += "file://less.cfg"
SRC_URI += "file://mountpoint.cfg"
SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', '', 'file://reboot.cfg', d)}"