summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph@in.ibm.com>2018-09-04 06:08:21 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-07 00:02:29 +0300
commit20b50ef352f967c123bee77475cb35022a40897c (patch)
tree7b9d5cb22ae6fcf5c230f177399f5198f71d97f7 /meta-phosphor/recipes-devtools
parent4df4f894a1abd71c55bc70afb2cc68377b3d36fd (diff)
downloadopenbmc-20b50ef352f967c123bee77475cb35022a40897c.tar.xz
Add python library pamela as a dependency of phosphor-rest-server
Pamela is a python wrapper for PAM. Compared to python-pam it has wrapper for account management in addition to authentication. (From meta-phosphor rev: 65c5362ac32389167766f51de4cd3f645fae0123) Change-Id: I5fee48e75d1b68b998fdb2971aad3802191ee1d5 Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb b/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb
new file mode 100644
index 000000000..8071fcb04
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Pamela: yet another Python wrapper for PAM"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bfb663f37eb99232bc8ccfa4ea8f1202"
+
+SRC_URI[md5sum] = "de6516118d51eb5fc97017f3b6d5c68b"
+SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a8355e5d6b"
+
+PYPI_PACKAGE = "pamela"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"