summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/pam
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-extended/pam
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-extended/pam')
-rw-r--r--meta-phosphor/recipes-extended/pam/libpam_%.bbappend6
-rw-r--r--meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
index 8ed05f629..682f132b5 100644
--- a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += " file://pam.d/common-password \
file://pam.d/common-account \
@@ -6,14 +6,14 @@ SRC_URI += " file://pam.d/common-password \
file://pam.d/common-session \
"
-RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
+RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
"
-do_install_append() {
+do_install:append() {
# The libpam recipe will always add a pam_systemd.so line to
# common-session if systemd is enabled; however systemd only
# builds pam_systemd.so if logind is enabled, and we disable
diff --git a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
index 30bcf6afb..a2bcb909c 100644
--- a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
+++ b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
@@ -16,7 +16,7 @@ inherit autotools pkgconfig
DEPENDS += "autoconf-archive-native"
DEPENDS += "openssl libpam"
-FILES_${PN} += " \
+FILES:${PN} += " \
${base_libdir}/security/ \
${sysconfdir}/key_file \
${sysconfdir}/ipmi_pass \