summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-04-08 18:26:49 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-10 18:05:57 +0300
commitf732694ec4945cf7373fab6261bd0262a112d733 (patch)
tree546d4cb9ee8b2fe436604fa2a66a9a5f8ea27594 /meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
parenta56471337332261a9af794f163dd134d1fe31e53 (diff)
downloadopenbmc-f732694ec4945cf7373fab6261bd0262a112d733.tar.xz
sdbusplus: remove unused python2 recipe
All recipes consuming sdbus++ have now migrated to the python3 version. Remove the python2 version. (From meta-phosphor rev: bb27bf20fa96141b4ac64262191b9ad0543e8a10) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Idae08e4354fa75a9acb3036b7ea7b873d396c4b8 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb31
1 files changed, 30 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index 829d4964b..bf815ce03 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,2 +1,31 @@
+SUMMARY = "sdbus++ dbus API / binding generator"
+DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
+
+inherit autotools pkgconfig
inherit obmc-phosphor-python3-autotools
-include sdbus++.inc
+
+include sdbusplus-rev.inc
+
+# Provide these aliases temporarily until everyone can move over to the
+# new package name.
+PROVIDES_class-native += "sdbusplus-native"
+PROVIDES_class-nativesdk += "sdbusplus-nativesdk"
+
+DEPENDS += " \
+ autoconf-archive-native \
+ ${PYTHON_PN}-inflection-native \
+ ${PYTHON_PN}-mako-native \
+ ${PYTHON_PN}-pyyaml-native \
+ "
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-inflection \
+ ${PYTHON_PN}-mako \
+ ${PYTHON_PN}-pyyaml \
+ "
+
+PACKAGECONFIG ??= "transaction"
+PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
+PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
+
+BBCLASSEXTEND += "native nativesdk"