summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/stdplus
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-03-22 07:20:35 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-26 23:46:15 +0300
commite24a3fd2dfe1c687a4efc418d7fee3baf5fec283 (patch)
tree5b75050dd49b59b4753757b48128b52268ad16a5 /meta-phosphor/recipes-extended/stdplus
parent4eceffc5e563f588b93ef53c7b35dfd83fad35fc (diff)
downloadopenbmc-e24a3fd2dfe1c687a4efc418d7fee3baf5fec283.tar.xz
stdplus: Add package
Ideally this would be using meson but our current version 0.47.2 is not new enough to support that yet. (From meta-phosphor rev: ed59c49fac0f553d626e1e3400e3e38f23248791) Change-Id: Iaaa2d3cdc92edf60c82c0b2ddca3d332b4cdac9d Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-extended/stdplus')
-rw-r--r--meta-phosphor/recipes-extended/stdplus/stdplus_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
new file mode 100644
index 000000000..4b5db3cb8
--- /dev/null
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Common C++ functions"
+DESCRIPTION = "Common C++ functions."
+HOMEPAGE = "http://github.com/openbmc/stdplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+ autoconf-archive-native \
+ "
+
+EXTRA_OECONF_append += " \
+ --disable-examples \
+ --disable-tests \
+ "
+
+SRC_URI += "git://github.com/openbmc/stdplus"
+SRCREV = "15982f6c0a252bc3642efb2df5d3c209e535c4fa"
+
+S = "${WORKDIR}/git"