summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/certificate
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2022-01-18 21:55:05 +0300
committerGitHub <noreply@github.com>2022-01-18 21:55:05 +0300
commit7cf0c1cd0ce835d1833509b7b911e8a97380278b (patch)
tree0b45c3beaa9874facc4ed1a2395a31e42be0135d /meta-phosphor/recipes-phosphor/certificate
parent4dac5fcd49b5e2de1074f1363775ec0f19041072 (diff)
parent1fc0d70f658da30091bcd49f9bf29aecd6b99ba7 (diff)
downloadopenbmc-7cf0c1cd0ce835d1833509b7b911e8a97380278b.tar.xz
Merge pull request #76 from Intel-BMC/update1-0.86
Update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/certificate')
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb30
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config/env12
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager/phosphor-certificate-manager@.service11
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb21
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb30
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config/env12
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb30
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env9
8 files changed, 15 insertions, 140 deletions
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
deleted file mode 100644
index 1d9f5a3b1..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Phosphor certificate manager configuration for a bmcweb service"
-
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-RDEPENDS:${PN} = "phosphor-certificate-manager"
-
-inherit allarch
-
-SRC_URI = "file://env"
-
-FILES:${PN} = "${datadir}"
-
-do_install() {
- install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/bmcweb
-}
-
-pkg_postinst:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
- TARGET="../phosphor-certificate-manager@.service"
- mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
- ln -s $TARGET $LINK
-}
-
-pkg_prerm:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
- rm $LINK
-}
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config/env b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config/env
deleted file mode 100644
index af4899a30..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config/env
+++ /dev/null
@@ -1,12 +0,0 @@
-#D-Bus object path
-#example: /xyz/openbmc_project/certs/server/https
-ENDPOINT=https
-
-#Path for the certificate file
-CERTPATH=/etc/ssl/certs/https/server.pem
-
-#Units to restart
-UNIT=bmcweb.service
-
-#Type of the service client/server
-TYPE=server
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager/phosphor-certificate-manager@.service b/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager/phosphor-certificate-manager@.service
deleted file mode 100644
index 255906fab..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager/phosphor-certificate-manager@.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Phosphor certificate manager for %I
-
-[Service]
-EnvironmentFile=/usr/share/phosphor-certificate-manager/%I
-ExecStart=/usr/bin/env phosphor-certificate-manager --endpoint=${{ENDPOINT}} --path=${{CERTPATH}} --unit=${{UNIT}} --type=${{TYPE}}
-SyslogIdentifier=phosphor-certificate-manager
-Restart=always
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
index 30730a4e3..b858958f0 100644
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
@@ -9,11 +9,11 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://github.com/openbmc/phosphor-certificate-manager"
-SRCREV = "811a29e1941db0157f49d2e05491be945f7b2f07"
+SRCREV = "7f7b47bea7bbd518d1ff5a306ecf3806cf8d0834"
inherit autotools \
pkgconfig \
- obmc-phosphor-systemd
+ systemd
DEPENDS = " \
autoconf-archive-native \
@@ -28,9 +28,18 @@ S = "${WORKDIR}/git"
EXTRA_OECONF += "--disable-tests"
-CERT_TMPL = "phosphor-certificate-manager@.service"
-SYSTEMD_SERVICE:${PN} = "${CERT_TMPL}"
+SYSTEMD_SERVICE:${PN} = "phosphor-certificate-manager@.service"
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "bmcweb-cert nslcd-authority-cert"
PACKAGECONFIG[ibm-hypervisor-cert] = "--enable-ca-cert-extension,,"
-SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'ibm-hypervisor-cert', 'bmc-vmi-ca-manager.service', '', d)}"
+PACKAGECONFIG[bmcweb-cert] = "--enable-bmcweb-cert-config,,"
+PACKAGECONFIG[nslcd-authority-cert] = "--enable-nslcd-authority-cert-config,,"
+
+SYSTEMD_SERVICE:${PN} = " \
+ phosphor-certificate-manager@.service \
+ ${@bb.utils.contains('PACKAGECONFIG', 'ibm-hypervisor-cert', 'bmc-vmi-ca-manager.service', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'nslcd-authority-cert', 'phosphor-certificate-manager@authority.service', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'bmcweb', 'phosphor-certificate-manager@bmcweb.service', '', d)} \
+ "
+
+FILES:${PN}:append = " ${systemd_system_unitdir}/* ${datadir}/dbus-1"
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb
deleted file mode 100644
index c847b6d7b..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Phosphor certificate manager configuration for an nslcd authority service"
-
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-RDEPENDS:${PN} = "phosphor-certificate-manager"
-
-inherit allarch
-
-SRC_URI = "file://env"
-
-FILES:${PN} = "${datadir}"
-
-do_install() {
- install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/authority
-}
-
-pkg_postinst:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
- TARGET="../phosphor-certificate-manager@.service"
- mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
- ln -s $TARGET $LINK
-}
-
-pkg_prerm:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
- rm $LINK
-}
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config/env b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config/env
deleted file mode 100644
index d2e8814cb..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config/env
+++ /dev/null
@@ -1,12 +0,0 @@
-#REST URI endpoint
-#example: /xyz/openbmc_project/certs/authority/ldap
-ENDPOINT=ldap
-
-#Path for the certificate file
-CERTPATH=/etc/ssl/certs/authority
-
-#Units to restart
-UNIT=bmcweb.service
-
-#Type of service
-TYPE=authority
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
deleted file mode 100644
index 7b1e26412..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Phosphor certificate manager configuration for a nslcd certificate"
-
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-RDEPENDS:${PN} = "phosphor-certificate-manager"
-
-inherit allarch
-
-SRC_URI = "file://env"
-
-FILES:${PN} = "${datadir}"
-
-do_install() {
- install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/nslcd
-}
-
-pkg_postinst:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@nslcd.service"
- TARGET="../phosphor-certificate-manager@.service"
- mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
- ln -s $TARGET $LINK
-}
-
-pkg_prerm:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@nslcd.service"
- rm $LINK
-}
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env
deleted file mode 100644
index 8ac1bf77e..000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env
+++ /dev/null
@@ -1,9 +0,0 @@
-#REST URI endpoint
-#example: /xyz/openbmc_project/certs/client/ldap
-ENDPOINT=ldap
-
-#Path for the certificate file
-CERTPATH=/etc/nslcd/certs/cert.pem
-
-#Type of the service client/server
-TYPE=client