summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-10 05:42:23 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 05:41:06 +0300
commita69d9ce1fa2b30d3538426196bad25482734b4b2 (patch)
tree687765f32a0d154a37fd0b9b3a955cd011b1f284 /meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
parentf03b1a369edbdd0596fca09b31de9b5c5cd27c4b (diff)
downloadopenbmc-a69d9ce1fa2b30d3538426196bad25482734b4b2.tar.xz
meta-phosphor: chassis: obmc-control-chassis: rename as git
obmc-control-chassis.bb inherits skeleton-python, which is git-based. (From meta-phosphor rev: 65b6f86249a2741912327668a89e7867c7960b4f) Change-Id: Ieceabb029edc0259cb18ed66328e46685109b501 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
new file mode 100644
index 000000000..affbccfe9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
+DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ python-netclient \
+ pyphosphor-dbus \
+ "
+
+SKELETON_DIR = "pychassisctl"
+
+FMT = "org.openbmc.control.Chassis@{0}.service"
+DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"