summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-08-19 02:30:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-13 18:05:53 +0300
commitc1371fdf473e2f24d44a36c7d8eb855eb917cd1f (patch)
tree3efcebce648222dcf05b1439808dd58cd2452f1b /meta-phosphor/recipes-phosphor/configuration
parentf55c875c26a532fd8dbd8d737c45a4f55a4b919f (diff)
downloadopenbmc-c1371fdf473e2f24d44a36c7d8eb855eb917cd1f.tar.xz
meta-phosphor: fru-device: add package
Add a fru-device package, packagegroup, and image feature. Remove the ipmi-fru distro feature, since adding it in the first place was a mistake - no projects have conditional ipmi-fru feature flags. (From meta-phosphor rev: 4525a9d01a5f65438342a894f27c82f0dd61642c) Change-Id: I6928ac67d4acb4568359a308b45cb0734d116054 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb19
1 files changed, 14 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index 4162b2b58..a32966330 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -9,10 +9,6 @@ PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
- ${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
-SYSTEMD_AUTO_ENABLE_${PN}_ibm-power-cpu = "disable"
-
DEPENDS = "boost \
nlohmann-json \
sdbusplus \
@@ -23,9 +19,22 @@ inherit meson systemd
EXTRA_OEMESON = "-Dtests=disabled"
-PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
+PACKAGECONFIG ??= "ipmi-fru"
PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
+EXTRA_ENTITY_MANAGER_PACKAGES = " \
+ ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
+ "
+
+PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
+
do_install_append() {
install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
}
+
+FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
+
+SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service"
+SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service"
+SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable"