summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-06-13 00:17:38 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-26 18:16:38 +0300
commitbd02cf92e36b22e2990b5c43aa8cb2407f1b5e2e (patch)
tree6aab36e71d87f96ee36ee0005b2582bbbf2a4ce5 /meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
parentd5956b61b8bc7995262ce31c167d72c053d6f585 (diff)
downloadopenbmc-bd02cf92e36b22e2990b5c43aa8cb2407f1b5e2e.tar.xz
meta-phosphor: phosphor-dbus-monitor non-native
Create the phosphor-dbus-monitor non-native recipe to allow the switch from native to non-native based recipes. This recipe is purposely not used until the system layer(s) are also prepared for the switch to non-native. Tested: Built witherspoon phosphor-dbus-monitor resulting in no image change (From meta-phosphor rev: 3af115ff3d4540d8559e5aa3bd3b57c77ad65711) Change-Id: Idc063b726134a5ff074be33a2cc53b9f974ded8f Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
new file mode 100644
index 000000000..6fadcae21
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phosphor DBus Monitor Configuration"
+DESCRIPTION = "Meta-recipe, pulling in non-native recipes that wish to add \
+configuration files to the /usr/share/phosphor-dbus-monitor filesystem."
+HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit phosphor-dbus-monitor
+
+PHOSPHOR_DBUS_MONITOR_CONFIGS ??= ""
+
+# To add additional config files, create a recipe in your layer,
+# and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe.
+
+DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
+
+do_install() {
+ mkdir -p ${D}${config_dir}
+}
+
+FILES_${PN} += "${config_dir}"