summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2021-05-04 06:16:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-06-17 16:17:10 +0300
commit858c97167568df269bd4191e2f020ca2623440d3 (patch)
tree5847443ab0b31b6753e3349fc75dc1d94ce4f51d /meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
parentce1a2e14897a1c5deb614023a717f9cfd4c79475 (diff)
downloadopenbmc-858c97167568df269bd4191e2f020ca2623440d3.tar.xz
meta-phosphor: Add debug-trigger recipe
debug-trigger listens for an external signal that the BMC is in some way unresponsive. When the signal is received it triggers a crash to collect debug data and reboots the system in the hope that it will recover. Change-Id: Ib8ea615c2944edb0448b06c333b6e2abbea15687 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
new file mode 100644
index 000000000..da168e2e8
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Debug trigger"
+DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
+HOMEPAGE = "https://github.com/openbmc/debug-trigger"
+
+SRC_URI = "git://github.com/openbmc/debug-trigger"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
+
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+SRCREV = "20017150d229401edc9bbf33fa48ceba7f94db47"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
+DEBUG_TRIGGERS ?= ""
+
+PACKAGECONFIG[systemd] = " \
+ -Dsystemd=true, \
+ -Dsystemd=false, \
+ systemd"
+
+PACKAGECONFIG[triggers] = " \
+ -Dtriggers=${DEBUG_TRIGGERS}, \
+ -Dtriggers=[], \
+ systemd udev"
+
+SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"