summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
commitbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (patch)
tree00457d3677e86437cec25fd7dab6c4513a53b1a4 /meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
parentcf6fd27dbd8e2d1b507f8c3752b85801b2c6ef57 (diff)
downloadopenbmc-bb6a14e2f317abf60677c6ad8de9c33d5760bf36.tar.xz
Merge tag '0.63' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
new file mode 100644
index 000000000..dd28e0f95
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Debug trigger"
+DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
+HOMEPAGE = "https://github.com/openbmc/debug-trigger"
+
+SRC_URI = "git://github.com/openbmc/debug-trigger"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
+
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+SRCREV = "15fe59cb0fc1430bdd05a85e7c7887ccc4e5c013"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
+DEBUG_TRIGGERS ?= ""
+
+PACKAGECONFIG[systemd] = " \
+ -Dsystemd=true, \
+ -Dsystemd=false, \
+ systemd"
+
+PACKAGECONFIG[triggers] = " \
+ -Dtriggers=${DEBUG_TRIGGERS}, \
+ -Dtriggers=[], \
+ systemd udev"
+
+SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"