summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2021-05-02 05:03:08 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-05-07 05:09:49 +0300
commit3b3898de80dbb3f780237045cd792298d12edede (patch)
tree8c16f92add9b91deec6d90e0c0483d57a7bc532f /meta-phosphor/recipes-phosphor/dump
parent24615567082edbe4c287e994f92fb94afcedf185 (diff)
downloadopenbmc-3b3898de80dbb3f780237045cd792298d12edede.tar.xz
debug-collector: Fix unclosed file in bb file
- The intent behind this commit is to fix the unclosed file in the phosphor-debug-collector_git.bb file. - When using `bitbake phosphor-debug-collector` to compile it, the warning message is: ResourceWarning: unclosed file <_io.TextIOWrapper name='phosphor-debug-collector/tools/dreport.d/plugins.d/hostlogger' mode='r' encoding='UTF-8'> install_dreport_user_script(srcname, d) Tested: built phosphor-debug-collector successfully and worked. Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: Id95b4a6369571db876acee0ed90953cd3874fff1
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 9854f05bc..374d32a07 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -161,6 +161,7 @@ def install_dreport_user_script(script_path, d):
linkname = "E" + priority + script
destlink = os.path.join(destdir, linkname)
os.symlink(srclink, destlink)
+ file.close()
#Make the links for all the plugins
python install_dreport_user_scripts() {