summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2021-03-09 08:59:35 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-07-22 13:49:22 +0300
commit99acb7602f454fd0175812ff62f5cbcc26d9a944 (patch)
treef6b9108a89c84c309671ae947fd4846484cc9443 /meta-phosphor/recipes-phosphor/dump
parentf05b3422bc4311e41d3fb11d3b11b97faad606f7 (diff)
downloadopenbmc-99acb7602f454fd0175812ff62f5cbcc26d9a944.tar.xz
dump: Add ramoops service
- Create a new package for the ramoops service and only load it once when the debug-collector daemon starts - Fix openbmc/phosphor-debug-collector#15 Tested: - Built obmc-phosphor-image and saw the ramoops-monitor run successfully. Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: Ic616408b834a257a981f0e0ef24ad030ccffc616
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector/ramoops-monitor.service13
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector/ramoops-monitor.service b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector/ramoops-monitor.service
new file mode 100644
index 000000000..efb95c39e
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector/ramoops-monitor.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Ramoops monitor.
+ConditionPathExists=/var/lib/systemd/pstore
+After=xyz.openbmc_project.Dump.Manager.service
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/phosphor-ramoops-monitor
+SyslogIdentifier=ramoops-monitor
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index fb799f2d6..41b2370e3 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -64,11 +64,13 @@ FILES_${PN}-manager += " \
${datadir}/dump/ \
"
FILES_${PN}-monitor += "${bindir}/phosphor-dump-monitor"
+FILES_${PN}-monitor += "${bindir}/phosphor-ramoops-monitor"
FILES_${PN}-dreport += "${bindir}/dreport"
FILES_${PN}-scripts += "${dreport_dir}"
DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
+SYSTEMD_SERVICE_${PN}-monitor += "ramoops-monitor.service"
EXTRA_OEMESON = " \
-DBMC_DUMP_PATH=${bmc_dump_path} \